libxine: remove older verison and add the actual 1.1.16
[openembedded.git] / recipes / tmake / tmake_1.11.bb
blob9d1ecd1a2a5845f4efb8307b74665be9c96281ee
1 SRC_URI = "ftp://ftp.trolltech.com/pub/freebies/tmake/tmake-${PV}.tar.gz"
2 DESCRIPTION = "tmake is an easy-to-use tool for creating and maintaining makefiles across many platforms and compilers."
3 LICENSE = "Unknown"
4 DEPENDS = ""
5 SECTION = "devel"
6 PRIORITY = "optional"
8 S = "${WORKDIR}/tmake-${PV}"
10 # Ick. This .bb file should really have a -native version doing this, even if it is a perl script... RP
11 do_stage() {
12 install -m 0755 bin/tmake bin/progen ${STAGING_BINDIR_NATIVE}/
14 install -d ${STAGING_DATADIR}/tmake
15 cp -R lib/* ${STAGING_DATADIR}/tmake/
18 do_install() {
19 install -d ${D}${bindir}
20 install -m 0755 bin/tmake bin/progen ${D}${bindir}/
22 install -d ${D}${datadir}/tmake
23 cp -R lib/* ${D}${datadir}/tmake/
26 PACKAGES = "${PN}-dbg tmake"
27 FILES = ""
28 FILES_tmake="${bindir} ${datadir}/tmake"