libxine: remove older verison and add the actual 1.1.16
[openembedded.git] / recipes / taglib / taglib_1.5.bb
blobf67660faf1222a4d4f4c3d19de0504f6b80d23bc
1 DESCRIPTION = "TagLib is a library for reading and editing the meta-data of several popular audio formats"
2 SECTION = "libs/multimedia"
3 HOMEPAGE = "http://developer.kde.org/~wheeler/taglib.html"
4 LICENSE = "LGPL"
5 PR = "r0"
7 SRC_URI = "http://developer.kde.org/~wheeler/files/src/taglib-${PV}.tar.gz \
8 file://add_missing_exports_fix.diff;patch=1 \
9 file://gcc_visibility_feature.diff;patch=1 \
10 file://link_interface_libraries_fix.diff;patch=1 \
13 S = "${WORKDIR}/taglib-${PV}"
15 inherit cmake pkgconfig binconfig
17 do_stage() {
18 install -d ${STAGING_INCDIR}/${PN}
19 install -m 0644 ${D}/usr/include/${PN}/*.h ${STAGING_INCDIR}/${PN}
20 oe_libinstall -C ${PN} -so libtag ${STAGING_LIBDIR}
23 LEAD_SONAME = "libtag.so.1"
25 PACKAGES =+ "${PN}-c"
27 FILES_${PN} = "${libdir}/libtag.so.*"
28 FILES_${PN}-c = "${libdir}/libtag_c.so.*"