libxine: remove older verison and add the actual 1.1.16
[openembedded.git] / recipes / maradns / maradns_1.0.41.bb
bloba8bed6f05ef0ca11010caa113f39e49ef0e6bd15
1 DESCRIPTION = "A security-aware DNS server"
2 SECTION = "console/network"
3 HOMEPAGE = "http://www.maradns.org"
4 LICENSE = "PD"
6 SRC_URI = "http://www.maradns.org/download/1.0/maradns-${PV}.tar.bz2 \
7 file://init \
8 file://rng-makefile-build-cc.patch;patch=1;pnum=0"
10 do_install() {
11 install -d ${D}${bindir}
12 install -d ${D}${sbindir}
13 install -d ${D}${sysconfdir}
14 install -d ${D}${sysconfdir}/mararc
15 install -d ${D}${sysconfdir}/init.d
16 install -d ${D}${mandir}/man1
17 install -d ${D}${mandir}/man5
18 install -d ${D}${mandir}/man8
20 sed -i -e "s:PREFIX/man:PREFIX/share/man:" \
21 -e "s:PREFIX/doc/maradns-\$VERSION:PREFIX/share/doc/${PF}:" \
22 build/install.locations
24 oe_runmake \
25 TOPLEVEL=${S} \
26 BUILDDIR=${S}/build \
27 RPM_BUILD_ROOT=${D} \
28 PREFIX=${D}/usr \
29 MAN1=${D}${mandir}/man1 \
30 MAN5=${D}${mandir}/man5 \
31 MAN8=${D}${mandir}/man8 \
32 install
34 mv ${D}${sysconfdir}/mararc/example_mararc ${D}${sysconfdir}/maradns/mararc
35 rm -r ${D}${sysconfdir}/mararc/
36 install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/maradns
39 PACKAGES =+ "maradns-zone maradns-ask"
40 FILES_maradns-zone = "${sbindir}/zoneserver ${bindir}/getzone"
41 FILES_maradns-ask = "${bindir}/askmara"
43 CONFFILES_${PN}_nylon = "/etc/maradns/mararc"