libxine: remove older verison and add the actual 1.1.16
[openembedded.git] / recipes / libssh / libssh_0.11.bb
blob833567ebb003a5f1814d29494701153da3f0cbdc
1 SECTION = "libs"
2 DESCRIPTION = "The SSH library is a C library to authenticate in a \
3 simple manner to one or more SSH servers. The goal of this project \
4 is to provide a library much simpler to use than OpenSSHs one. It \
5 includes SFTP support, and a sample SSH client is provided."
6 DEPENDS = "openssl"
7 LICENSE = "LGPL"
9 DEFAULT_PREFERENCE="-1"
11 SRC_URI = "http://www.0xbadc0de.be/libssh/libssh-${PV}.tgz"
13 inherit autotools
15 EXTRA_OECONF = "--cache-file=${S}/config.cache"
17 do_stage () {
18 set -x
19 install -d ${STAGING_INCDIR}/libssh
20 for i in crypto.h libssh.h sftp.h ssh2.h; do
21 install -m 0644 ${S}/include/libssh/$i ${STAGING_INCDIR}/libssh/
22 done
23 oe_libinstall -so -C libssh libssh ${STAGING_LIBDIR}
26 do_install () {
27 oe_runmake "prefix=${D}${prefix}" \
28 "exec_prefix=${D}${exec_prefix}" \
29 "bindir=${D}${bindir}" \
30 "incldir=${D}${includedir}" \
31 "infodir=${D}${infodir}" \
32 "mandir=${D}${mandir}/man1" \
33 "libdir=${D}${libdir}" \
34 install