clearsilver: fix various build issues
[openembedded.git] / recipes / libogg / libogg_1.1.3.bb
blob0a6e827ff10e94dd03a9509685da69a96b0f0efa
1 SECTION = "libs"
2 DESCRIPTION = "libogg is the bitstream and framing library \
3 for the Ogg project. It provides functions which are \
4 necessary to codec libraries like libvorbis."
5 LICENSE = "BSD"
7 SRC_URI = "http://downloads.xiph.org/releases/ogg/libogg-${PV}.tar.gz"
9 inherit autotools pkgconfig
11 do_stage () {
12 oe_libinstall -a -so -C src libogg ${STAGING_LIBDIR}
14 install -d ${STAGING_INCDIR}/ogg
15 (cd ${S}/include/ogg; cp config_types.h ogg.h os_types.h ${STAGING_INCDIR}/ogg/)
16 install -m 0644 ${S}/ogg.m4 ${STAGING_DATADIR}/aclocal/