Initial commit contains ebuild for xf86-video-openchrome driver and modified ebuilds for
[openchrome.git] / x11-drivers / xf86-video-openchrome / xf86-video-openchrome-9999.ebuild
blobe991307c3e853de8f537429fdd4b0ba679e833dd
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit x-modular subversion
7 DESCRIPTION="openChrome graphics driver for VIA/S3G cards"
8 HOMEPAGE="http://www.openchrome.org"
9 SRC_URI=""
11 ESVN_PROJECT="openchrome-svn"
12 ESVN_BOOTSTRAP="eautoreconf"
13 # ESVN_REPO_URI="http://svn.openchrome.org/svn/trunk"
16 KEYWORDS="-*"
17 # waiting for info on
18 # http://wiki.openchrome.org/pipermail/openchrome-users/2007-October/003641.html
19 #IUSE="dri"
20 #CONFIGURE_OPTIONS="$(use_enable dri)"
21 IUSE="experimental xrandr"
23 RDEPEND=">=x11-base/xorg-server-1.2
24 x11-libs/libXvMC"
26 DEPEND="${RDEPEND}
27 !x11-drivers/openchrome
28 !x11-drivers/xf86-video-via
29 x11-proto/fontsproto
30 x11-proto/randrproto
31 x11-proto/renderproto
32 x11-proto/xextproto
33 x11-proto/xproto
34 x11-proto/xf86driproto
35 x11-proto/glproto
36 x11-libs/libdrm
37 x11-libs/libX11"
38 # dri? ( x11-proto/xf86driproto
39 # x11-proto/glproto
40 # x11-libs/libdrm
41 # x11-libs/libX11 )"
43 src_unpack() {
44 if use experimental; then
45 if use xrandr; then
46 die "You can choose only one custom branch"
48 einfo "Using experimental openChrome driver branch"
49 export ESVN_REPO_URI="http://svn.openchrome.org/svn/branches/experimental_branch"
50 else
51 if use xrandr; then
52 einfo "Using xrandr openChrome driver branch"
53 export ESVN_REPO_URI="http://svn.openchrome.org/svn/branches/randr_branch"
54 else
55 einfo "Using trunk openChrome driver branch"
56 export ESVN_REPO_URI="http://svn.openchrome.org/svn/trunk"
58 fi
59 subversion_src_unpack
63 pkg_setup() {
64 # as we currently can't turn dri support off
65 #if use dri && ! built_with_use x11-base/xorg-server dri; then
66 if ! built_with_use x11-base/xorg-server dri; then
67 die "Build x11-base/xorg-server with USE=\"dri\"."