Initial commit contains ebuild for xf86-video-openchrome driver and modified ebuilds for
[openchrome.git] / x11-drivers / xf86-video-openchrome / xf86-video-openchrome-0.2.901.ebuild
blobf1ae76c68a4cf2298ef4ad39903d57c723b3a997
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 #SNAPSHOT="yes"
6 XDPVER=-1
8 inherit x-modular
10 DESCRIPTION="openChrome graphics driver for VIA/S3G cards"
11 HOMEPAGE="http://www.openchrome.org"
12 SRC_URI="http://www.openchrome.org/releases/${P}.tar.bz2"
14 KEYWORDS="~amd64 ~ia64 ~x86 ~x86-fbsd"
15 # waiting for info on
16 # http://wiki.openchrome.org/pipermail/openchrome-users/2007-October/003641.html
17 #IUSE="dri"
18 #CONFIGURE_OPTIONS="$(use_enable dri)"
20 RDEPEND=">=x11-base/xorg-server-1.2
21 x11-libs/libXvMC"
23 DEPEND="${RDEPEND}
24 x11-proto/fontsproto
25 x11-proto/randrproto
26 x11-proto/renderproto
27 x11-proto/xextproto
28 x11-proto/xproto
29 x11-proto/xf86driproto
30 x11-proto/glproto
31 x11-libs/libdrm
32 x11-libs/libX11"
33 # dri? ( x11-proto/xf86driproto
34 # x11-proto/glproto
35 # x11-libs/libdrm
36 # x11-libs/libX11 )"
38 pkg_setup() {
39 # as we currently can't turn dri support off
40 # because of http://openchrome.org/trac/ticket/137
41 #if use dri && ! built_with_use x11-base/xorg-server dri; then
42 if ! built_with_use x11-base/xorg-server dri; then
43 die "Build x11-base/xorg-server with USE=\"dri\"."