changelogentry for new revision
[opeanno-debian-packaging.git] / debian / patches / local_config_goes_to_homedir
blob3bcea3bf3b374a2df95f4a06521223f4247d7ad5
1 Index: openanno/game/settings.py
2 ===================================================================
3 --- openanno.orig/game/settings.py      2008-11-08 18:30:48.000000000 +0100
4 +++ openanno/game/settings.py   2008-11-08 18:47:13.000000000 +0100
5 @@ -23,6 +23,7 @@
6  import shutil
7  import os.path
8  import simplejson
9 +import os
11  class Setting(object):
12         """ Class to store settings
13 @@ -114,7 +115,7 @@
14         """
15         @param config:
16         """
17 -       def __init__(self, config = 'config.sqlite'):
18 +       def __init__(self, config = '%s/.openanno/config.sqlite' % os.getenv('HOME')):
19                 if not os.path.exists(config):
20                         shutil.copyfile('content/config.sqlite', config)
21                 game.main.db("ATTACH ? AS config", config)