distrib: run libtoolize
[nvi.git] / README.DB3
blob58b4a6237c559fcae0b646f43ac6117b7abef72d
1 This version of vi requires DB3.1 or better, which can be found
2 on http://www.sleepycat.com/ .
4 Note that there is a small problem with DB 3.2 in that it will
5 not let nvi read in a final line that doesn't end in a newline.
6 This should be fixed in DB 3.3
8 If your system library (such as glibc prior to version 2.2) uses a
9 previous version of db (e.g. DB2) internally, you must configure with
10 --enable-dynamic-loading to avoid symbols in the internally used db from
11 being resolved against the newer db.
13 If, on top of that, the vi binary is explicitly linked against that
14 previous version of db (such as might happen if you enable the perl
15 embedding), you should compile the 3.x version with all symbols internally
16 resolved.  In case you use the Gnu linker (ld), this can be accomplished
17 by passing it the -Bsymbolic option. You can do this by setting CC
18 to e.g. "gcc -Wl,-Bsymbolic" prior to configuring db.
19 See docs/ref/build_unix/flags.html in the db distribution for more
20 information.
22 skimo@kotnet.org