2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
5 # Uncomment this to turn on verbose mode.
11 PKGDIR
= debian
/${PACKAGE}
12 DOCDIR
= /usr
/share
/doc
/${PACKAGE}
13 LISPDIR
= /usr
/share
/emacs
/site-lisp
/${PACKAGE}
15 configure
: configure-stamp
18 # Add here commands to configure the package.
22 build
: configure-stamp build-stamp
26 makeinfo --html
--output
=html muse.texi
27 # Add here commands to compile the package.
30 #/usr/bin/docbook-to-man debian/muse.sgml > muse.1
37 rm -f build-stamp configure-stamp
38 # Add here commands to clean up after the build process.
49 # Add here commands to install the package into debian/muse.
50 # $(MAKE) install DESTDIR=$(CURDIR)/debian/muse
51 install -m
644 lisp
/*.el
$(PKGDIR
)$(LISPDIR
)
52 install -m
644 experimental
/*.el
$(PKGDIR
)$(LISPDIR
)/experimental
53 install -m
644 contrib
/*.el
$(PKGDIR
)$(LISPDIR
)/contrib
54 install -m
644 contrib
/pyblosxom
/*.py
$(PKGDIR
)$(DOCDIR
)/contrib
/pyblosxom
57 install -m
0644 AUTHORS
${PKGDIR}${DOCDIR}/AUTHORS
58 install -m
0644 NEWS
${PKGDIR}${DOCDIR}/NEWS
59 install -m
0644 README
${PKGDIR}${DOCDIR}/README
60 install -m
0644 ChangeLog
${PKGDIR}${DOCDIR}/changelog
61 cat ChangeLog
.2004 >> ${PKGDIR}${DOCDIR}/changelog
63 # Build architecture-independent files here.
64 binary-indep
: build
install
65 # We have nothing to do by default.
67 # Build architecture-dependent files here.
68 binary-arch
: build
install
97 binary
: binary-indep binary-arch
98 .PHONY
: build
clean binary-indep binary-arch binary
install configure