Release Emacs Muse 3.02.01.
[muse-el.git] / debian / rules
blobcb355d77a95fc7f55cb8b74aeeb4c0aa6b76041e
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
7 LANG=C
8 LC_CTYPE=C
10 PACKAGE = muse-el
11 PKGDIR = debian/${PACKAGE}
12 DOCDIR = /usr/share/doc/${PACKAGE}
13 LISPDIR = /usr/share/emacs/site-lisp/${PACKAGE}
15 # This is the debhelper compatibility version to use.
16 export DH_COMPAT=3
18 configure: configure-stamp
19 configure-stamp:
20 dh_testdir
21 # Add here commands to configure the package.
23 touch configure-stamp
25 build: configure-stamp build-stamp
26 build-stamp:
27 dh_testdir
28 makeinfo muse.texi
29 makeinfo --html --output=html muse.texi
30 # Add here commands to compile the package.
31 $(MAKE) examples
32 #/usr/bin/docbook-to-man debian/muse.sgml > muse.1
34 touch build-stamp
36 clean:
37 dh_testdir
38 dh_testroot
39 rm -f build-stamp configure-stamp
40 # Add here commands to clean up after the build process.
41 -$(MAKE) realclean
43 dh_clean
45 install: build
46 dh_testdir
47 dh_testroot
48 dh_clean -k
49 dh_installdirs
51 # Add here commands to install the package into debian/muse.
52 # $(MAKE) install DESTDIR=$(CURDIR)/debian/muse
53 install -m 644 lisp/*.el $(PKGDIR)$(LISPDIR)
54 install -m 644 experimental/*.el $(PKGDIR)$(LISPDIR)/experimental
55 install -m 644 contrib/*.el $(PKGDIR)$(LISPDIR)/contrib
56 install -m 644 contrib/pyblosxom/*.py $(PKGDIR)$(DOCDIR)/contrib/pyblosxom
58 # Other documentation
59 install -m 0644 AUTHORS ${PKGDIR}${DOCDIR}/AUTHORS
60 install -m 0644 debian/NEWS ${PKGDIR}${DOCDIR}/NEWS.Debian
61 install -m 0644 README ${PKGDIR}${DOCDIR}/README
62 install -m 0644 ChangeLog ${PKGDIR}${DOCDIR}/changelog
63 cat ChangeLog.2004 >> ${PKGDIR}${DOCDIR}/changelog
65 # Build architecture-independent files here.
66 binary-indep: build install
67 # We have nothing to do by default.
69 # Build architecture-dependent files here.
70 binary-arch: build install
71 dh_testdir
72 dh_testroot
73 # dh_installdebconf
74 dh_installdocs
75 dh_installexamples
76 # dh_installmenu
77 # dh_installlogrotate
78 dh_installemacsen
79 # dh_installpam
80 # dh_installmime
81 # dh_installinit
82 # dh_installcron
83 # dh_installman
84 dh_installinfo
85 # dh_undocumented
86 dh_installchangelogs
87 dh_link
88 dh_strip
89 dh_compress
90 dh_fixperms
91 # dh_makeshlibs
92 dh_installdeb
93 # dh_perl
94 # dh_shlibdeps
95 dh_gencontrol
96 dh_md5sums
97 dh_builddeb
99 binary: binary-indep binary-arch
100 .PHONY: build clean binary-indep binary-arch binary install configure