10l for me
[mplayer/greg.git] / debian / rules
blobf484bbe17639d07e913d17fb7654cb97377477f3
1 #!/usr/bin/make -f
2 # Made with the aid of debmake, by Christoph Lameter,
3 # based on the sample debian/rules file for GNU hello by Ian Jackson.
4 #export DH_VERBOSE=1
5 # This is the debhelper compatability version to use.
6 export DH_COMPAT=3
8 package := mplayer
9 prefix := $(shell pwd)/debian/$(package)
11 arch := $(shell dpkg --print-architecture)
14 configure: configure-stamp
15 configure-stamp:
16 dh_testdir
17 # Add here commands to configure the package.
18 $(checkdir)
19 ./configure --prefix=/usr --confdir=/etc/mplayer --enable-runtime-cpudetection --enable-gui $(DEB_BUILD_OPTIONS)
21 touch configure-stamp
23 build: configure-stamp build-stamp
24 build-stamp:
25 dh_testdir
27 # commands to compile the package.
28 ${MAKE}
30 touch build-stamp
32 clean:
33 dh_testdir
34 dh_testroot
35 rm -f build-stamp configure-stamp
37 # commands to clean up after the build process.
38 -$(MAKE) distclean
39 rm -f help_mp.h config.h config.mak libao2/config.mak libvo/config.mak Gui/config.mak
40 dh_clean
42 # Build architecture-independent files here.
43 binary-indep: build
44 # We have nothing to do by default.
46 # Build architecture-dependent files here.
47 binary-arch: build
48 dh_testdir
49 dh_testroot
50 dh_clean -k
51 dh_installdirs
53 # commands to install the package into debian/<packagename>
54 $(MAKE) prefix=$(prefix)/usr BINDIR=$(prefix)/usr/bin CONFDIR=$(prefix)/etc/mplayer LIBDIR=$(prefix)/usr/lib DATADIR=$(prefix)/usr/share/mplayer MANDIR=$(prefix)/usr/share/man install
56 dh_link usr/bin/mplayer usr/bin/gmplayer \
57 usr/share/man/man1/mplayer.1.gz usr/share/man/man1/gmplayer.1.gz
60 dh_installdebconf
61 dh_installdocs --exclude=CVS --exclude=mplayer.1 DOCS/*
62 dh_installexamples etc/example.conf etc/dvb-menu.conf etc/input.conf etc/menu.conf
63 dh_installmenu
64 dh_installmime
65 dh_installinfo
66 dh_installchangelogs
67 #ChangeLog
68 dh_link
69 dh_strip
70 dh_compress
71 dh_fixperms
72 # dh_makeshlibs
73 dh_installdeb
74 dh_perl
75 dh_shlibdeps
76 dh_gencontrol
77 dh_md5sums
78 dh_builddeb
82 #binary-arch: checkroot build
83 # $(checkdir)
84 # -rm -rf debian/tmp
85 # install -d debian/tmp
86 # cd debian/tmp && install -d `cat ../dirs`
89 # Must have debmake installed for this to work. Otherwise please copy
90 # /usr/bin/debstd into the debian directory and change debstd to debian/debstd
91 # debstd
92 # dpkg-gencontrol -isp
93 # chown -R root.root debian/tmp
94 # chmod -R go=rX debian/tmp
95 # dpkg --build debian/tmp ..
97 binary: binary-indep binary-arch
99 .PHONY: binary binary-arch binary-indep clean checkroot