Support VDPAU hardware accelerated decoding of MPEG-4 ASP on capable
[mplayer/greg.git] / debian / rules
blob17c06b062159bd2a06093ac0d4b1fd1902992d75
1 #!/usr/bin/make -f
2 # Made with the aid of debmake, by Christoph Lameter,
3 # based on the sample debian/rules file for GNU hello by Ian Jackson.
4 #export DH_VERBOSE=1
5 # This is the debhelper compatability version to use.
6 export DH_COMPAT=4
8 package := mplayer
9 prefix := $(shell pwd)/debian/$(package)
11 arch := $(shell dpkg --print-architecture)
13 # See http://wiki.debian.org/Teams/Dpkg/DebianRules; #465282 and
14 # https://wiki.ubuntu.com/DistCompilerFlags
15 CLEAN_ENV=env -u CFLAGS -u CPPFLAGS -u LDFLAGS -u FFLAGS -u CXXFLAGS
17 configure: configure-stamp
18 configure-stamp:
19 dh_testdir
20 # Add here commands to configure the package.
21 $(checkdir)
22 # If you plan to install the target .deb on a wide variety of machines,
23 # you may want to add the "--enable-runtime-cpudetection" option to
24 # the line below, but beware: the resulting binary will run slower
25 $(CLEAN_ENV) \
26 ./configure --prefix=/usr --confdir=/etc/mplayer $(DEB_BUILD_OPTIONS)
28 touch configure-stamp
30 build: configure-stamp build-stamp
31 build-stamp:
32 dh_testdir
34 # commands to compile the package.
35 $(CLEAN_ENV) \
36 ${MAKE}
38 touch build-stamp
40 clean:
41 dh_testdir
42 dh_testroot
43 rm -f build-stamp configure-stamp
45 # commands to clean up after the build process.
46 -$(MAKE) distclean
47 rm -f help_mp.h config.h config.mak
48 dh_clean
50 # Build architecture-independent files here.
51 binary-indep: build
52 # We have nothing to do by default.
54 # Build architecture-dependent files here.
55 binary-arch: build
56 dh_testdir
57 dh_testroot
58 dh_clean -k
59 dh_installdirs
61 # commands to install the package into debian/<packagename>
62 $(MAKE) prefix=$(prefix)/usr BINDIR=$(prefix)/usr/bin CONFDIR=$(prefix)/etc/mplayer LIBDIR=$(prefix)/usr/lib DATADIR=$(prefix)/usr/share/mplayer MANDIR=$(prefix)/usr/share/man install
64 dh_link usr/bin/mplayer usr/bin/gmplayer \
65 usr/share/man/man1/mplayer.1.gz usr/share/man/man1/gmplayer.1.gz
68 dh_installdebconf
69 dh_installdocs -X.svn -Xmplayer.1 DOCS/*
70 dh_installexamples etc/example.conf etc/dvb-menu.conf etc/input.conf etc/menu.conf
71 dh_installmenu
72 dh_installmime
73 dh_installinfo
74 dh_installchangelogs
75 #ChangeLog
76 dh_link
77 dh_strip
78 dh_compress
79 dh_fixperms
80 dh_makeshlibs
81 dh_installdeb
82 dh_perl
83 dh_shlibdeps
84 dh_gencontrol
85 dh_md5sums
86 dh_builddeb
90 #binary-arch: checkroot build
91 # $(checkdir)
92 # -rm -rf debian/tmp
93 # install -d debian/tmp
94 # cd debian/tmp && install -d `cat ../dirs`
97 # Must have debmake installed for this to work. Otherwise please copy
98 # /usr/bin/debstd into the debian directory and change debstd to debian/debstd
99 # debstd
100 # dpkg-gencontrol -isp
101 # chown -R root.root debian/tmp
102 # chmod -R go=rX debian/tmp
103 # dpkg --build debian/tmp ..
105 binary: binary-indep binary-arch
107 .PHONY: binary binary-arch binary-indep clean checkroot