2 # Made with the aid of debmake, by Christoph Lameter,
3 # based on the sample debian/rules file for GNU hello by Ian Jackson.
5 # This is the debhelper compatability version to use.
9 prefix := $(shell pwd
)/debian
/$(package
)
11 arch
:= $(shell dpkg
--print-architecture
)
14 configure
: configure-stamp
17 # Add here commands to configure the package.
19 .
/configure
--prefix=/usr
--confdir
=/etc
/mplayer
--enable-runtime-cpudetection
--enable-gui
$(DEB_BUILD_OPTIONS
)
23 build
: configure-stamp build-stamp
27 # commands to compile the package.
35 rm -f build-stamp configure-stamp
37 # commands to clean up after the build process.
39 rm -f help_mp.h config.h config.mak libao2
/config.mak libvo
/config.mak Gui
/config.mak
42 # Build architecture-independent files here.
44 # We have nothing to do by default.
46 # Build architecture-dependent files here.
53 # commands to install the package into debian/<packagename>
54 $(MAKE
) prefix=$(prefix)/usr BINDIR
=$(prefix)/usr
/bin CONFDIR
=$(prefix)/etc
/mplayer LIBDIR
=$(prefix)/usr
/lib DATADIR
=$(prefix)/usr
/share
/mplayer MANDIR
=$(prefix)/usr
/share
/man
install
55 dh_link usr
/bin
/mplayer usr
/bin
/gmplayer \
56 usr
/share
/man
/man1
/mplayer
.1.gz usr
/share
/man
/man1
/gmplayer
.1.gz
60 dh_installdocs
--exclude
=CVS
--exclude
=mplayer
.1 DOCS
/*
61 dh_installexamples etc
/example.conf etc
/dvb-menu.conf etc
/input.conf etc
/menu.conf
81 #binary-arch: checkroot build
84 # install -d debian/tmp
85 # cd debian/tmp && install -d `cat ../dirs`
88 # Must have debmake installed for this to work. Otherwise please copy
89 # /usr/bin/debstd into the debian directory and change debstd to debian/debstd
91 # dpkg-gencontrol -isp
92 # chown -R root.root debian/tmp
93 # chmod -R go=rX debian/tmp
94 # dpkg --build debian/tmp ..
96 binary
: binary-indep binary-arch
98 .PHONY
: binary binary-arch binary-indep
clean checkroot