2 # Made with the aid of debmake, by Christoph Lameter,
3 # based on the sample debian/rules file for GNU hello by Ian Jackson.
6 # do not run the actual rules of this makefile in parallel. sub-makes
11 prefix := $(shell pwd
)/debian
/$(package
)
13 arch
:= $(shell dpkg
--print-architecture
)
15 # See http://wiki.debian.org/Teams/Dpkg/DebianRules; #465282 and
16 # https://wiki.ubuntu.com/DistCompilerFlags
17 CLEAN_ENV
=env
-u CFLAGS
-u CPPFLAGS
-u LDFLAGS
-u FFLAGS
-u CXXFLAGS
19 ifneq (,$(filter parallel
=%,$(DEB_BUILD_OPTIONS
)))
20 NUMJOBS
= $(patsubst parallel
=%,%,$(filter parallel
=%,$(DEB_BUILD_OPTIONS
)))
21 MAKEFLAGS
+= -j
$(NUMJOBS
)
24 configure
: configure-stamp
27 # Add here commands to configure the package.
29 # If you plan to install the target .deb on a wide variety of machines,
30 # you may want to add the "--enable-runtime-cpudetection" option to
31 # the line below, but beware: the resulting binary will run slower
33 .
/configure
--prefix=/usr
--confdir
=/etc
/mplayer
$(DEB_BUILD_CONFIGURE
)
37 build
: configure-stamp build-stamp
41 # commands to compile the package.
50 rm -f build-stamp configure-stamp
52 # commands to clean up after the build process.
56 # Build architecture-independent files here.
58 # We have nothing to do by default.
60 # Build architecture-dependent files here.
67 # commands to install the package into debian/<packagename>
68 $(MAKE
) prefix=$(prefix)/usr BINDIR
=$(prefix)/usr
/bin CONFDIR
=$(prefix)/etc
/mplayer LIBDIR
=$(prefix)/usr
/lib DATADIR
=$(prefix)/usr
/share
/mplayer MANDIR
=$(prefix)/usr
/share
/man
install
70 install -D
-m
644 etc
/example.conf
$(prefix)/etc
/mplayer
/mplayer.conf
71 dh_installdocs
-X.svn
-Xmplayer
.1 DOCS
/*
72 dh_installexamples etc
/example.conf etc
/dvb-menu.conf etc
/input.conf etc
/menu.conf
91 #binary-arch: checkroot build
94 # install -d debian/tmp
95 # cd debian/tmp && install -d `cat ../dirs`
98 # Must have debmake installed for this to work. Otherwise please copy
99 # /usr/bin/debstd into the debian directory and change debstd to debian/debstd
101 # dpkg-gencontrol -isp
102 # chown -R root.root debian/tmp
103 # chmod -R go=rX debian/tmp
104 # dpkg --build debian/tmp ..
106 binary
: binary-indep binary-arch
108 .PHONY
: binary binary-arch binary-indep
clean checkroot