2 # Made with the aid of debmake, by Christoph Lameter,
3 # based on the sample debian/rules file for GNU hello by Ian Jackson.
5 # This is the debhelper compatability version to use.
9 prefix := $(shell pwd
)/debian
/$(package
)
11 arch
:= $(shell dpkg
--print-architecture
)
14 configure
: configure-stamp
17 # Add here commands to configure the package.
19 # If you plan to install the target .deb on a wide variety of machines,
20 # you may want to add the "--enable-runtime-cpudetection" option to
21 # the line below, but beware: the resulting binary will run slower
22 .
/configure
--prefix=/usr
--confdir
=/etc
/mplayer
$(DEB_BUILD_OPTIONS
)
26 build
: configure-stamp build-stamp
30 # commands to compile the package.
38 rm -f build-stamp configure-stamp
40 # commands to clean up after the build process.
42 rm -f help_mp.h config.h config.mak
45 # Build architecture-independent files here.
47 # We have nothing to do by default.
49 # Build architecture-dependent files here.
56 # commands to install the package into debian/<packagename>
57 $(MAKE
) prefix=$(prefix)/usr BINDIR
=$(prefix)/usr
/bin CONFDIR
=$(prefix)/etc
/mplayer LIBDIR
=$(prefix)/usr
/lib DATADIR
=$(prefix)/usr
/share
/mplayer MANDIR
=$(prefix)/usr
/share
/man
install
59 dh_link usr
/bin
/mplayer usr
/bin
/gmplayer \
60 usr
/share
/man
/man1
/mplayer
.1.gz usr
/share
/man
/man1
/gmplayer
.1.gz
64 dh_installdocs
-X.svn
-Xmplayer
.1 DOCS
/*
65 dh_installexamples etc
/example.conf etc
/dvb-menu.conf etc
/input.conf etc
/menu.conf
85 #binary-arch: checkroot build
88 # install -d debian/tmp
89 # cd debian/tmp && install -d `cat ../dirs`
92 # Must have debmake installed for this to work. Otherwise please copy
93 # /usr/bin/debstd into the debian directory and change debstd to debian/debstd
95 # dpkg-gencontrol -isp
96 # chown -R root.root debian/tmp
97 # chmod -R go=rX debian/tmp
98 # dpkg --build debian/tmp ..
100 binary
: binary-indep binary-arch
102 .PHONY
: binary binary-arch binary-indep
clean checkroot