phpmp: Sync with gentoo
[mpd.git] / media-libs / libmpd / libmpd-9999.ebuild
blobfe5df2d7a4bf6e5d357772c0c351cfc9040f9451
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI=4
6 inherit autotools git-2
8 DESCRIPTION="A library handling connections to a MPD server"
9 HOMEPAGE="http://gmpc.wikia.com/wiki/Libmpd"
10 EGIT_REPO_URI="git://git.musicpd.org/master/${PN}.git"
11 EGIT_BOOTSTRAP="eautoreconf"
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS=""
16 IUSE="doc static-libs"
18 RDEPEND=">=dev-libs/glib-2.16:2"
19 DEPEND="${RDEPEND}
20 virtual/pkgconfig
21 doc? ( app-doc/doxygen )"
23 src_configure() {
24 econf \
25 $(use_enable static-libs static) \
26 --docdir="${EPREFIX}"/usr/share/doc/${PF}
29 src_compile() {
30 emake
31 use doc && emake -C doc doc
34 src_install() {
35 default
36 use doc && dohtml -r doc/html/*
37 find "${ED}" -name "*.la" -exec rm -rf {} + || die
38 rm "${ED}"/usr/share/doc/${PF}/{README,ChangeLog} || die