ncmpc: Sync with gentoo
[mpd.git] / media-sound / mpdscribble / mpdscribble-9999.ebuild
blobbd13596bab5a4b11fa7da69922acda313f559f7d
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI=4
6 inherit autotools git-2
8 DESCRIPTION="An MPD client that submits information to Audioscrobbler"
9 HOMEPAGE="http://mpd.wikia.com/wiki/Client:Mpdscribble"
10 EGIT_REPO_URI="git://git.musicpd.org/master/mpdscribble.git"
11 EGIT_BOOTSTRAP="eautoreconf"
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS=""
16 IUSE="+curl"
18 RDEPEND=">=dev-libs/glib-2.16:2
19 ~media-libs/libmpdclient-9999
20 curl? ( net-misc/curl )
21 !curl? ( net-libs/libsoup:2.4 )"
22 DEPEND="${RDEPEND}
23 virtual/pkgconfig"
25 src_configure() {
26 local myclient=soup
27 use curl && myclient=curl
28 econf \
29 --with-http-client=${myclient} \
30 --docdir="${EPREFIX}"/usr/share/doc/${PF}
33 src_install() {
34 default
35 newinitd "${FILESDIR}/mpdscribble.rc" mpdscribble
36 dodir /var/cache/mpdscribble