Updated README.
[mp_doccer.git] / debian / rules
blob5cbe9edc9c287b419f6de2095b802663c817183e
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
15 CFLAGS = -Wall -g
17 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
18 CFLAGS += -O0
19 else
20 CFLAGS += -O2
21 endif
23 configure: configure-stamp
24 configure-stamp:
25 dh_testdir
26 # Add here commands to configure the package.
28 touch configure-stamp
31 build: build-stamp
33 build-stamp: configure-stamp
34 dh_testdir
36 touch $@
38 clean:
39 dh_testdir
40 dh_testroot
41 rm -f build-stamp configure-stamp
43 # Add here commands to clean up after the build process.
44 -$(MAKE) clean
46 dh_clean
48 install: build
49 dh_testdir
50 dh_testroot
51 dh_clean -k
52 dh_installdirs
54 # Add here commands to install the package into debian/mpdoccer.
55 $(MAKE) install PREFIX=$(CURDIR)/debian/mpdoccer/usr
58 # Build architecture-independent files here.
59 binary-indep: build install
60 # We have nothing to do by default.
62 # Build architecture-dependent files here.
63 binary-arch: build install
64 dh_testdir
65 dh_testroot
66 # dh_installchangelogs Changelog
67 dh_installdocs
68 dh_installexamples
69 # dh_install
70 # dh_installmenu
71 # dh_installdebconf
72 # dh_installlogrotate
73 # dh_installemacsen
74 # dh_installpam
75 # dh_installmime
76 # dh_python
77 # dh_installinit
78 # dh_installcron
79 # dh_installinfo
80 dh_installman
81 dh_link
82 dh_strip
83 dh_compress
84 dh_fixperms
85 # dh_perl
86 # dh_makeshlibs
87 dh_installdeb
88 dh_shlibdeps
89 dh_gencontrol
90 dh_md5sums
91 dh_builddeb
93 binary: binary-indep binary-arch
94 .PHONY: build clean binary-indep binary-arch binary install configure