Remove unmaintained packages - #557728 @bgo
[moonrise.git] / x11-terms / lilyterm / lilyterm-0.9.9_rc8.ebuild
blobbebe70871e5c38790b6fcd31a3be2a4b61d9f3c1
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="2"
6 inherit versionator autotools
8 MY_P=${PN}-$(replace_version_separator 3 '~')
10 DESCRIPTION="A light and easy to use libvte based X terminal emulator"
11 HOMEPAGE="http://lilyterm.luna.com.tw"
12 SRC_URI="${HOMEPAGE}/file/${MY_P}.tar.gz"
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="~x86 ~amd64"
17 IUSE="nls"
18 RDEPEND=">=x11-libs/gtk+-2.8.20
19 >=x11-libs/vte-0.12
20 >=dev-libs/glib-2.12.4"
21 DEPEND="${RDEPEND}
22 dev-util/pkgconfig
23 dev-util/intltool
24 sys-devel/gettext
25 nls? ( sys-devel/gettext )"
27 S=${WORKDIR}/${MY_P}
28 RESTRICT="mirror"
30 src_prepare() {
31 sed -e '/examplesdir/s/\$(PACKAGE)/&-\${PV}/' \
32 -i data/Makefile.am || die "sed failed"
34 ./autogen.sh || die "autogen.sh failed with exit code $?"
35 econf \
36 $(use_enable nls)
39 src_install() {
40 emake DESTDIR="${D}" install || die "emake install failed."
41 dodoc AUTHORS ChangeLog README TODO || die "dodoc failed"