Remove unmaintained packages - #557728 @bgo
[moonrise.git] / x11-misc / lightdm / lightdm-0.3.0.ebuild
blobff9edf23eead47734bbfb6dd8fa44fd861d46605
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/x11-misc/lightdm/lightdm-0.1.2.ebuild,v 1.2 2010/11/01 18:36:34 ssuominen Exp $
5 EAPI=2
6 inherit autotools eutils pam
8 DESCRIPTION="A lightweight display manager"
9 HOMEPAGE="http://launchpad.net/lightdm"
10 SRC_URI="http://people.ubuntu.com/~robert-ancell/${PN}/releases/${P}.tar.gz"
12 LICENSE="GPL-3 LGPL-3"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="gtk +introspection nls qt4 webkit"
17 RDEPEND="dev-libs/glib:2
18 dev-libs/dbus-glib
19 x11-libs/libxcb
20 x11-libs/libXdmcp
21 x11-libs/libxklavier
22 virtual/pam
23 introspection? ( dev-libs/gobject-introspection )
24 gtk? ( x11-libs/gtk+:2 )
25 webkit? ( net-libs/webkit-gtk )
26 qt4? ( x11-libs/qt-gui:4
27 sys-auth/consolekit )"
28 DEPEND="${RDEPEND}
29 dev-util/pkgconfig
30 nls? ( dev-util/intltool )"
32 src_prepare() {
33 epatch "${FILESDIR}"/${PN}-gentoo.patch
34 sed -e "/^SUBDIRS/d" -i data/Makefile.am || die
35 eautoreconf
38 src_configure() {
39 econf \
40 --localstatedir=/var \
41 --disable-dependency-tracking \
42 --disable-static \
43 $(use_enable webkit liblightdm-webkit) \
44 $(use_enable qt4 liblightdm-qt) \
45 $(use_enable gtk liblightdm-gtk) \
46 $(use_enable introspection) \
47 $(use_enable nls) \
48 --with-html-dir=/usr/share/doc/${PF}/html
51 src_install() {
52 emake DESTDIR="${D}" install || die
53 pamd_mimic system-local-login lightdm auth account session
54 dodoc ChangeLog NEWS || die
55 find "${D}" -name '*.la' -exec rm -f '{}' +