Remove unmaintained packages - #557728 @bgo
[moonrise.git] / net-libs / libtorrent / libtorrent-0.12.7.ebuild
blobc52fe53d29cb10ebe4532cc363a008e506471fda
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.12.6.ebuild,v 1.8 2010/12/08 02:50:00 vapier Exp $
5 EAPI=2
6 inherit eutils libtool toolchain-funcs
8 DESCRIPTION="BitTorrent library written in C++ for *nix"
9 HOMEPAGE="http://libtorrent.rakshasa.no/"
10 SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ~arm hppa ~ia64 ppc ppc64 ~sparc x86 ~x86-fbsd"
15 IUSE="debug ipv6 ssl"
17 RDEPEND=">=dev-libs/libsigc++-2.2.2:2
18 ssl? ( dev-libs/openssl )"
19 DEPEND="${RDEPEND}
20 dev-util/pkgconfig"
22 src_configure() {
23 # the configure check for posix_fallocate is wrong.
24 # reported upstream as Ticket 2416.
25 local myconf
26 echo "int main(){return posix_fallocate();}" > "${T}"/posix_fallocate.c
27 if $(tc-getCC) ${CFLAGS} ${LDFLAGS} "${T}"/posix_fallocate.c -o /dev/null 2>/dev/null ; then
28 myconf="--with-posix-fallocate"
29 else
30 myconf="--without-posix-fallocate"
33 econf \
34 --disable-dependency-tracking \
35 --enable-aligned \
36 $(use_enable debug) \
37 $(use_enable ipv6) \
38 $(use_enable ssl openssl) \
39 ${myconf}
42 src_install() {
43 emake DESTDIR="${D}" install || die
44 dodoc AUTHORS NEWS README