Remove unmaintained packages - #557728 @bgo
[moonrise.git] / games-util / grfcodec / grfcodec-5.1.1.ebuild
blobd2a1cfc45b637ef0138d7c44a354993ac31a337b
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/games-util/grfcodec/grfcodec-0_pre2306.ebuild,v 1.7 2010/10/15 13:49:56 maekke Exp $
5 EAPI=2
6 inherit eutils toolchain-funcs
8 DESCRIPTION="A suite of programs to modify openttd/Transport Tycoon Deluxe's GRF files"
9 HOMEPAGE="http://binaries.openttd.org/extra/grfcodec/"
10 SRC_URI="http://binaries.openttd.org/extra/grfcodec/${PV}/${PN}-${PV}-source.tar.gz"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE=""
17 S=${WORKDIR}/${PN}-${PV}-source
19 DEPEND="dev-lang/perl
20 dev-libs/boost"
21 RDEPEND=""
23 src_prepare() {
24 cat > Makefile.local <<-__EOF__
25 CC = $(tc-getCC)
26 CXX = $(tc-getCXX)
27 CFLAGS = ${CFLAGS}
28 CXXFLAGS = ${CXXFLAGS}
29 LDOPT = ${LDFLAGS}
30 STRIP = :
31 V = 1
32 __EOF__
35 src_compile() {
36 make
39 src_install() {
40 dobin ${PN} grf{diff,merge} nforenum || die