screenfo and Term-ExtendedColor: add keywords
[moonrise.git] / app-misc / screenfo / screenfo-9999.ebuild
blobcca7918c358dc1480e7ce8cb32af11f54c9f02ec
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI=2
7 inherit git
9 EGIT_REPO_URI="git://github.com/trapd00r/screenfo.git"
11 DESCRIPTION="screenshot information tool for nerds"
12 HOMEPAGE="https://github.com/trapd00r/screenfo"
13 SRC_URI=""
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
19 RDEPEND=">=dev-lang/perl-5.10
20 =dev-perl/Term-ExtendedColor-9999"
21 DEPEND="${RDEPEND}"
23 src_prepare() {
24 cd ${WORKDIR}/${P}
25 /usr/bin/perl Makefile.PL
28 src_install() {
29 emake DESTDIR="${D}" install
31 mkdir ${D}/etc/
32 cp ${WORKDIR}/${P}/screenfo.conf ${D}/etc/
33 mkdir ${D}/usr/share/screenfo/
34 cp -R ${WORKDIR}/${P}/ascii ${D}/usr/share/screenfo/