Committer: Michael Beasley <mike@snafu.setup>
[mikesnafu-overlay.git] / sys-fs / btrfs-progs / btrfs-progs-0.13.ebuild
blobdf43905d7264b1ba679f126e7e70968780af595d
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit eutils
7 DESCRIPTION="btrfs filesystem utilities"
8 HOMEPAGE="http://oss.oracle.com/projects/btrfs/"
9 SRC_URI="http://oss.oracle.com/projects/btrfs/dist/files/${P}.tar.bz2"
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64"
14 IUSE=""
16 DEPEND=""
17 RDEPEND="${RDEPEND}
18 sys-fs/e2fsprogs"
20 src_unpack() {
21 unpack ${A}
22 cd "${S}"
23 # Change installation directory to a more suitable place
24 epatch "${FILESDIR}"/${P}-makefile.patch
27 src_compile() {
28 emake || die "emake failed"
31 src_install() {
32 emake DESTDIR="${D}" install || die "install failed"
35 pkg_postinst() {
36 einfo
37 einfo "The Btrfs disk format is not yet finalized and it currently does not"
38 einfo "handle disk full conditions at all. Things are under heavy development"
39 einfo "and Btrfs is not suitable for any uses other than benchmarking and review."
40 einfo
41 einfo "Documentation and the kernel module can be found at."
42 einfo "http://oss.oracle.com/projects/btrfs"
43 einfo