Added cs to the list of languages
[midnight-commander.git] / mc.spec
blob5b8e4a912b271a667ad8115f66be8b6e51287726
1 # Note that this is NOT a relocatable package
2 %define ver 4.5.7
3 %define prefix /usr
5 Summary: Midnight Commander visual shell
6 Name: mc
7 Version: %ver
8 Release: %rel
9 Copyright: GPL
10 Group: Shells
11 Source0: ftp://ftp.nuclecu.unam.mx/linux/local/devel/mc-%{PACKAGE_VERSION}.tar.gz
12 URL: http://www.gnome.org/mc/
13 BuildRoot: /tmp/mc-%{PACKAGE_VERSION}-root
14 Requires: pam >= 0.59
15 Prereq: /sbin/chkconfig
17 %description
18 Midnight Commander is a visual shell much like a file manager, only with way
19 more features. It is text mode, but also includes mouse support if you are
20 running GPM. Its coolest feature is the ability to ftp, view tar, zip
21 files, and poke into RPMs for specific files. :-)
23 %package -n gmc
24 Summary: Midnight Commander visual shell (GNOME version)
25 Requires: mc >= 4.1.31
26 Group: X11/Shells
27 %description -n gmc
28 Midnight Commander is a visual shell much like a file manager, only with
29 way more features. This is the GNOME version. It's coolest feature is the
30 ability to ftp, view tar, zip files and poke into RPMs for specific files.
31 The GNOME version of Midnight Commander is not yet finished though. :-(
33 %package -n mcserv
34 Summary: Midnight Commander file server
35 Group: X11/Shells
36 Requires: portmap
37 %description -n mcserv
38 mcserv is the server program for the Midnight Commander networking file
39 system. It provides access to the host file system to clients running the
40 Midnight file system (currently, only the Midnight Commander file manager).
42 %prep
43 %setup
45 %build
46 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" ./configure \
47 --prefix=%{prefix} \
48 --with-gnome \
49 --without-debug
51 if [ "$SMP" != "" ]; then
52 (make "MAKE=make -k -j $SMP"; exit 0)
53 make
54 else
55 make
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,pam.d,profile.d,X11/wmconfig}
62 make prefix=$RPM_BUILD_ROOT%{prefix} install
63 (cd icons; make prefix=$RPM_BUILD_ROOT%{prefix} install_icons)
64 install lib/mcserv.init $RPM_BUILD_ROOT/etc/rc.d/init.d/mcserv
66 install lib/mcserv.pamd $RPM_BUILD_ROOT/etc/pam.d/mcserv
67 install lib/{mc.sh,mc.csh} $RPM_BUILD_ROOT/etc/profile.d
69 # clean up this setuid problem for now
70 chmod 755 $RPM_BUILD_ROOT/usr/lib/mc/bin/cons.saver
72 %clean
73 rm -rf $RPM_BUILD_ROOT
75 %post -n mcserv
76 /sbin/chkconfig --add mcserv
78 %postun -n mcserv
79 /sbin/chkconfig --del mcserv
81 %files
82 %defattr(-, root, root)
84 %doc FAQ COPYING NEWS README
85 /usr/bin/mc
86 /usr/bin/mcedit
87 /usr/bin/mcmfmt
88 /usr/lib/mc/mc.ext
89 /usr/lib/mc/mc.hint
90 /usr/lib/mc/mc.hlp
91 /usr/lib/mc/mc.lib
92 /usr/lib/mc/mc.menu
93 /usr/lib/mc/bin/cons.saver
94 /usr/lib/mc/extfs/*
95 /usr/man/man1/*
96 %config /etc/profile.d/*
97 %dir /usr/lib/mc
98 %dir /usr/lib/mc/bin
99 %dir /usr/lib/mc/extfs
100 %dir /usr/share/mime-info
102 %files -n mcserv
103 %defattr(-, root, root)
105 %config /etc/pam.d/mcserv
106 %config /etc/rc.d/init.d/mcserv
107 %attr(-, root, man) /usr/man/man8/mcserv.8
108 /usr/bin/mcserv
110 %files -n gmc
111 %defattr(-, root, root)
113 /usr/bin/gmc
114 /usr/lib/mc/layout
115 /usr/share/pixmaps/mc/*
117 %changelog
118 * Thu Aug 20 1998 Michael Fulbright <msf@redhat.com>
119 - rebuilt against gnome-libs 0.27 and gtk+-1.1
121 * Thu Jul 09 1998 Michael Fulbright <msf@redhat.com>
122 - made cons.saver not setuid
124 * Sun Apr 19 1998 Marc Ewing <marc@redhat.com>
125 - removed tkmc
127 * Wed Apr 8 1998 Marc Ewing <marc@redhat.com>
128 - add /usr/lib/mc/layout to gmc
130 * Tue Dec 23 1997 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
131 - added --without-debug to configure,
132 - modification in %build and %install and cosmetic modification in packages
133 headers,
134 - added %%{PACKAGE_VERSION} macro to Buildroot,
135 - removed "rm -rf $RPM_BUILD_ROOT" from %prep.
136 - removed Packager field.
138 * Thu Dec 18 1997 Michele Marziani <marziani@fe.infn.it>
139 - Merged spec file with that from RedHat-5.0 distribution
140 (now a Hurricane-based distribution is needed)
141 - Added patch for RPM script (didn't always work with rpm-2.4.10)
142 - Corrected patch for mcserv init file (chkconfig init levels)
143 - Added more documentation files on termcap, terminfo, xterm
145 * Thu Oct 30 1997 Michael K. Johnson <johnsonm@redhat.com>
147 - Added dependency on portmap
149 * Wed Oct 29 1997 Michael K. Johnson <johnsonm@redhat.com>
151 - fixed spec file.
152 - Updated to 4.1.8
154 * Sun Oct 26 1997 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
156 - updated to 4.1.6
157 - added %attr macros in %files,
158 - a few simplification in %install,
159 - removed glibc patch,
160 - fixed installing /etc/X11/wmconfig/tkmc.
162 * Thu Oct 23 1997 Michael K. Johnson <johnsonm@redhat.com>
164 - updated to 4.1.5
165 - added wmconfig
167 * Wed Oct 15 1997 Erik Troan <ewt@redhat.com>
169 - chkconfig is for mcserv package, not mc one
171 * Tue Oct 14 1997 Erik Troan <ewt@redhat.com>
173 - patched init script for chkconfig
174 - don't turn on the service by default
176 * Fri Oct 10 1997 Michael K. Johnson <johnsonm@redhat.com>
178 - Converted to new PAM conventions.
179 - Updated to 4.1.3
180 - No longer needs glibc patch.
182 * Thu May 22 1997 Michele Marziani <marziani@fe.infn.it>
184 - added support for mc alias in /etc/profile.d/mc.csh (for csh and tcsh)
185 - lowered number of SysV init scripts in /etc/rc.d/rc[0,1,6].d
186 (mcserv needs to be killed before inet)
187 - removed all references to $RPM_SOURCE_DIR
188 - restored $RPM_OPT_FLAGS when compiling
189 - minor cleanup of spec file: redundant directives and comments removed
191 * Sun May 18 1997 Michele Marziani <marziani@fe.infn.it>
193 - removed all references to non-existent mc.rpmfs
194 - added mcedit.1 to the %files section
195 - reverted to un-gzipped man pages (RedHat style)
196 - removed double install line for mcserv.pamd
198 * Tue May 13 1997 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
200 - added new rpmfs script,
201 - removed mcfn_install from mc (adding mc() to bash enviroment is in
202 /etc/profile.d/mc.sh),
203 - /etc/profile.d/mc.sh changed to %config,
204 - removed /usr/lib/mc/bin/create_vcs,
205 - removed /usr/lib/mc/term.
207 * Wed May 9 1997 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
209 - changed source url,
210 - fixed link mcedit to mc,
212 * Tue May 7 1997 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
214 - new version 3.5.27,
215 - %dir /usr/lib/mc/icons and icons removed from tkmc,
216 - added commented xmc part.
218 * Tue Apr 22 1997 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
220 - FIX spec:
221 - added URL field,
222 - in mc added missing /usr/lib/mc/mc.ext, /usr/lib/mc/mc.hint,
223 /usr/lib/mc/mc.hlp, /usr/lib/mc/mc.lib, /usr/lib/mc/mc.menu.
225 * Fri Apr 18 1997 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
227 - added making packages: tkmc, mcserv (xmc not work yet),
228 - gziped man pages,
229 - added /etc/pamd.d/mcserv PAM config file.
230 - added instaling icons,
231 - added /etc/profile.d/mc.sh,
232 - in %doc added NEWS README,
233 - removed /usr/lib/mc/FAQ,
234 - added mcserv.init script for mcserv (start/stop on level 86).