import from sf.net
[maemopadplus.git] / debian / rules
blobf4acd02bd07982a541df0ec41ebf8d1e594eafde
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # GNU copyright 1997 to 1999 by Joey Hess.
6 # Uncomment this to turn on verbose mode.
7 #export DH_VERBOSE=1
10 # These are used for cross-compiling and for saving the configure script
11 # from having to guess our platform (since we know it already)
12 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
13 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
16 CFLAGS = -Wall -g
17 PACKAGENAME = maemopad+
19 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
20 CFLAGS += -O0
21 else
22 CFLAGS += -O2
23 endif
24 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
25 INSTALL_PROGRAM += -s
26 endif
28 config.status: configure
29 dh_testdir
30 # Add here commands to configure the package.
31 CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
34 build: build-stamp
36 build-stamp: config.status
37 dh_testdir
39 # Add here commands to compile the package.
40 $(MAKE)
41 touch build-stamp
43 clean:
44 dh_testdir
45 dh_testroot
46 rm -f build-stamp
48 # Add here commands to clean up after the build process.
49 -$(MAKE) distclean
51 dh_clean
53 install: build
54 dh_testdir
55 dh_testroot
56 dh_clean -k
57 dh_installdirs
59 # Add here commands to install the package into debian/tmp
60 #$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp/var/lib/install
61 $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
64 # Build architecture-independent files here.
65 binary-indep: build install
66 # We have nothing to do by default.
68 # Build architecture-dependent files here.
69 binary-arch: build install
70 dh_testdir
71 dh_testroot
72 dh_link
73 dh_strip
74 dh_compress
75 dh_fixperms
76 dh_installdeb
77 dh_shlibdeps
78 dh_gencontrol
79 dh_md5sums
80 dh_builddeb
82 binary: binary-indep binary-arch
83 .PHONY: build clean binary-indep binary-arch binary install