Initial Chinook port. Requires libwpeditor-plus. Menu/Tools/Color doesn't work.
[maemopadplus.git] / debian / rules
blob995070ed6fe43c32723f8d39c956465a80ae970f
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # GNU copyright 1997 to 1999 by Joey Hess.
6 # Uncomment this to turn on verbose mode.
7 #export DH_VERBOSE=1
10 # These are used for cross-compiling and for saving the configure script
11 # from having to guess our platform (since we know it already)
12 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
13 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
16 CFLAGS = -Wall -g
17 PACKAGENAME = maemopadplus
19 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
20 CFLAGS += -O0
21 else
22 CFLAGS += -O2
23 endif
24 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
25 INSTALL_PROGRAM += -s
26 endif
28 config.status: configure
29 dh_testdir
30 # Add here commands to configure the package.
31 CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
34 build: build-stamp
36 build-stamp: config.status
37 dh_testdir
39 # Add here commands to compile the package.
40 $(MAKE)
41 touch build-stamp
43 clean:
44 dh_testdir
45 dh_testroot
46 rm -f build-stamp
48 # Add here commands to clean up after the build process.
49 -$(MAKE) distclean
51 dh_clean
53 install: build
54 dh_testdir
55 dh_testroot
56 dh_clean -k
57 dh_installdirs
59 # Add here commands to install the package into debian/tmp
60 $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
63 # Build architecture-independent files here.
64 binary-indep: build install
65 # We have nothing to do by default.
67 # Build architecture-dependent files here.
68 binary-arch: build install
69 dh_testdir
70 dh_testroot
71 dh_link
72 dh_strip
73 dh_compress
74 dh_fixperms
75 dh_installdeb
76 dh_shlibdeps
77 dh_gencontrol
78 dh_md5sums
79 dh_builddeb
81 binary: binary-indep binary-arch
82 .PHONY: build clean binary-indep binary-arch binary install