3 # We deduce the target based on the available version of the Maemo SDK
4 ifeq (1,$(shell pkg-config
--atleast-version
=5 maemo-version
&& echo
1))
10 CONFIGURE_OPTIONS
:= --target
=$(TARGET
) --ram
=8 --rbdir
=/.rockbox
--type
=N
11 DESKTOP_DIR
:= `pkg-config --variable=desktopentrydir osso-af-settings`
16 test -d builddir || mkdir
-p builddir
18 builddir
/Makefile
: builddir
19 cd builddir
&& test -f Makefile || ..
/tools
/configure
$(CONFIGURE_OPTIONS
)
23 build-stamp
: builddir
/Makefile
25 cd builddir
&& $(MAKE
)
40 cd builddir
&& $(MAKE
) PREFIX
=$(CURDIR
)/debian
/rockbox
/opt
/rockbox fullinstall
42 # Install icon and .desktop file
43 mkdir
-p
$(CURDIR
)/debian
/rockbox
/usr
/share
/icons
/hicolor
/64x64
/apps
44 cp
-f debian
/maemo
/rockbox.png
$(CURDIR
)/debian
/rockbox
/usr
/share
/icons
/hicolor
/64x64
/apps
45 mkdir
-p
$(CURDIR
)/debian
/rockbox
$(DESKTOP_DIR
)
46 cp
-f debian
/maemo
/rockbox.desktop
$(CURDIR
)/debian
/rockbox
$(DESKTOP_DIR
)
48 # Ignore built in sounds
49 mkdir
-p
$(CURDIR
)/debian
/rockbox
/usr
/share
/sounds
50 touch
$(CURDIR
)/debian
/rockbox
/usr
/share
/sounds
/database.ignore
52 # Build architecture-independent files here.
54 # We have nothing to do by default.
56 # Build architecture-dependent files here.
57 binary-arch
: build
install
64 dh_strip
--dbg-package
=rockbox-dbg
73 binary
: binary-indep binary-arch
74 .PHONY
: build
clean binary-indep binary-arch binary
install configure