The threading model should be set from configure, not config.h.
[maemo-rb.git] / packaging / rpm / rockbox.spec
blob88b3251bc51371506a26676f7adc4f3c2ee58736
1 # Set svn_revision to SVN revision number if you want to do a SVN build.
2 # Parent source directory has to be "rockbox-rXXXXX"
3 %define svn_revision 0
5 %if 0%{?svn_revision}
6 # SVN rockbox build
7 Version: r%{svn_revision}
8 %else
9 # Normal rockbox release
10 Version: 3.8
11 %endif
13 Name: rockbox
14 Summary: High quality audio player
15 License: GPL
16 Group: Applications/Multimedia
17 Vendor: rockbox.org
18 Release: 1%{?dist}
19 Url: http://www.rockbox.org
20 Buildroot: %{_tmppath}/%{name}-%{version}-root
21 Requires: SDL
22 BuildRequires: SDL-devel
23 # Note: rpm doesn't support 7z. You need to repack as .tar.bz2
24 # Source: http://download.rockbox.org/release/%{version}/%{name}-%{version}.7z
25 Source: %{name}-%{version}.tar.bz2
26 Prefix: /opt/rockbox
28 %description
29 Rockbox open source high quality audio player
31 Features:
32 - Supports over 20 sound codecs:
33 MP3, OGG, WAV, FLAC and many more
34 - Navigate music by folders or tag database
35 - Gapless playback and crossfading
36 - Ability to create your own themes
37 - Album art support
39 Need more reasons?
40 Find them here: http://www.rockbox.org/wiki/WhyRockbox
42 %prep
43 %setup -q
45 %build
46 mkdir build
47 cd build
49 ../tools/configure --prefix=%{prefix} --target=sdlapp --lcdwidth=800 --lcdheight=480 --type=N
51 make %{?_smp_mflags}
53 %install
54 cd build
55 make PREFIX=$RPM_BUILD_ROOT/%{prefix} fullinstall
57 %clean
58 rm -fr $RPM_BUILD_ROOT
60 %files
61 %defattr(-,root,root)
62 %{prefix}/bin/rockbox
63 %{prefix}/lib/*
64 %{prefix}/share/*