Added compat shims in fs.py for old api
[livecd/EL-5.git] / livecd-tools.spec
blobce4fea8919d8acb00d618224bcb59a67d4901a17
1 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "import distutils.sysconfig as d; print d.get_python_lib()")}
3 %define debug_package %{nil}
5 Summary: Tools for building live CD's
6 Name: livecd-tools
7 Version: 017
8 Release: 1%{?dist}
9 License: GPLv2
10 Group: System Environment/Base
11 URL: http://git.fedoraproject.org/?p=hosted/livecd
12 Source0: %{name}-%{version}.tar.bz2
13 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14 Requires: util-linux
15 Requires: coreutils
16 Requires: e2fsprogs
17 Requires: yum >= 3.1.7
18 Requires: mkisofs
19 Requires: squashfs-tools
20 Requires: pykickstart >= 0.96
21 Requires: dosfstools >= 2.11-8
22 Requires: isomd5sum
23 %ifarch %{ix86} x86_64
24 Requires: syslinux
25 %endif
26 %ifarch ppc ppc64
27 Requires: yaboot
28 %endif
29 BuildRequires: python
30 BuildRequires: /usr/bin/pod2man
33 %description
34 Tools for generating live CD's on Fedora based systems including
35 derived distributions such as RHEL, CentOS and others. See
36 http://fedoraproject.org/wiki/FedoraLiveCD for more details.
38 %prep
39 %setup -q
41 %build
42 make
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 make install DESTDIR=$RPM_BUILD_ROOT
48 %clean
49 rm -rf $RPM_BUILD_ROOT
51 %files
52 %defattr(-,root,root,-)
53 %doc AUTHORS COPYING README HACKING
54 %{_mandir}/man*/*
55 %{_bindir}/livecd-creator
56 %{_bindir}/livecd-iso-to-disk
57 %{_bindir}/livecd-iso-to-pxeboot
58 %dir %{_datadir}/livecd-tools
59 %{_datadir}/livecd-tools/*
60 %{_bindir}/image-creator
61 %dir %{python_sitelib}/imgcreate
62 %{python_sitelib}/imgcreate/*.py
63 %{python_sitelib}/imgcreate/*.pyo
64 %{python_sitelib}/imgcreate/*.pyc
66 %changelog
67 * Tue May 6 2008 Bill Nottingham <notting@redhat.com> - 017-1
68 - fix F9 final configs
70 * Thu May 1 2008 Jeremy Katz <katzj@redhat.com> - 016-1
71 - Config changes all around, including F9 final configs
72 - Fix up the minimal image creation
73 - Fix odd traceback error on __del__ (#442443)
74 - Add late initscript and split things in half
75 - livecd-iso-to-disk: Check the available space on the stick (#443046)
76 - Fix partition size overriding (kanarip)
78 * Thu Mar 6 2008 Jeremy Katz <katzj@redhat.com> - 015-1
79 - Support for using live isos with pxe booting (Richard W.M. Jones and
80 Chris Lalancette)
81 - Fixes for SELinux being disabled (Warren Togami)
82 - Stop using mayflower for building the initrd; mkinitrd can do it now
83 - Create a minimal /dev rather than using the host /dev (Warren Togami)
84 - Support for persistent overlays when using a USB stick (based on support
85 by Douglas McClendon)
87 * Tue Feb 12 2008 Jeremy Katz <katzj@redhat.com> - 014-1
88 - Rework to provide a python API for use by other tools (thanks to
89 markmc for a lot of the legwork here)
90 - Fix creation of images with ext2 filesystems and no SELinux
91 - Don't require a yum-cache directory inside of the cachedir (#430066)
92 - Many config updates for rawhide
93 - Allow running live images from MMC/SD (#430444)
94 - Don't let a non-standard TMPDIR break things (Jim Meyering)
96 * Mon Oct 29 2007 Jeremy Katz <katzj@redhat.com> - 013-1
97 - Lots of config updates
98 - Support 'device foo' to say what modules go in the initramfs
99 - Support multiple kernels being installed
100 - Allow blacklisting kernel modules on boot with blacklist=foo
101 - Improve bootloader configs
102 - Split configs off for f8
104 * Tue Sep 25 2007 Jeremy Katz <katzj@redhat.com> - 012-1
105 - Allow %%post --nochroot to work for putting files in the root of the iso
106 - Set environment variables for when %%post is run
107 - Add progress for downloads (Colin Walters)
108 - Add cachedir option (Colin Walters)
109 - Fixes for ppc/ppc64 to work again
110 - Clean up bootloader config a little
111 - Enable swaps in the default desktop config
112 - Ensure all configs are installed (#281911)
113 - Convert method line to a repo for easier config reuse (jkeating)
114 - Kill the modprobe FATAL warnings (#240585)
115 - Verify isos with iso-to-disk script
116 - Allow passing xdriver for setting the xdriver (#291281)
117 - Add turboliveinst patch (Douglas McClendon)
118 - Make iso-to-disk support --resetmbr (#294041)
119 - Clean up filesystem layout (Douglas McClendon)
120 - Manifest tweaks for most configs
122 * Tue Aug 28 2007 Jeremy Katz <katzj@redhat.com> - 011-1
123 - Many config updates for Fedora 8
124 - Support $basearch in repo line of configs; use it
125 - Support setting up Xen kernels and memtest86+ in the bootloader config
126 - Handle rhgb setup
127 - Improved default fs label (Colin Walters)
128 - Support localboot from the bootloader (#252192)
129 - Use hidden menu support in syslinux
130 - Have a base desktop config included by the other configs (Colin Walters)
131 - Use optparse for optino parsing
132 - Remove a lot of command line options; things should be specified via the
133 kickstart config instead
134 - Beginnings of PPC support (David Woodhouse)
135 - Clean up kernel module inclusion to take advantage of files in Fedora
136 kernels listing storage drivers
138 * Wed Jul 25 2007 Jeremy Katz <katzj@redhat.com> - 010-1
139 - Separate out configs used for Fedora 7
140 - Add patch from Douglas McClendon to make images smaller
141 - Add patch from Matt Domsch to work with older syslinux without vesamenu
142 - Add support for using mirrorlists; use them
143 - Let livecd-iso-to-disk work with uncompressed images (#248081)
144 - Raise error if SELinux requested without being enabled (#248080)
145 - Set service defaults on level 2 also (#246350)
146 - Catch some failure cases
147 - Allow specifying tmpdir
148 - Add patch from nameserver specification from Elias Hunt
150 * Wed May 30 2007 Jeremy Katz <katzj@redhat.com> - 009-1
151 - miscellaneous live config changes
152 - fix isomd5 checking syntax error
154 * Fri May 4 2007 Jeremy Katz <katzj@redhat.com> - 008-1
155 - disable screensaver with default config
156 - add aic7xxx and sym53c8xx drivers to default initramfs
157 - fixes from johnp for FC6 support in the creator
158 - fix iso-to-stick to work on FC6
160 * Tue Apr 24 2007 Jeremy Katz <katzj@redhat.com> - 007-1
161 - Disable prelinking by default
162 - Disable some things that slow down the live boot substantially
163 - Lots of tweaks to the default package manifests
164 - Allow setting the root password (Jeroen van Meeuwen)
165 - Allow more specific network line setting (Mark McLoughlin)
166 - Don't pollute the host yum cache (Mark McLoughlin)
167 - Add support for mediachecking
169 * Wed Apr 4 2007 Jeremy Katz <katzj@redhat.com> - 006-1
170 - Many fixes to error handling from Mark McLoughlin
171 - Add the KDE config
172 - Add support for prelinking
173 - Fixes for installing when running from RAM or usb stick
174 - Add sanity checking to better ensure that USB stick is bootable
176 * Thu Mar 29 2007 Jeremy Katz <katzj@redhat.com> - 005-3
177 - have to use excludearch, not exclusivearch
179 * Thu Mar 29 2007 Jeremy Katz <katzj@redhat.com> - 005-2
180 - exclusivearch since it only works on x86 and x86_64 for now
182 * Wed Mar 28 2007 Jeremy Katz <katzj@redhat.com> - 005-1
183 - some shell quoting fixes
184 - allow using UUID or LABEL for the fs label of a usb stick
185 - work with ext2 formated usb stick
187 * Mon Mar 26 2007 Jeremy Katz <katzj@redhat.com> - 004-1
188 - add livecd-iso-to-disk for setting up the live CD iso image onto a usb
189 stick or similar
191 * Fri Mar 23 2007 Jeremy Katz <katzj@redhat.com> - 003-1
192 - fix remaining reference to run-init
194 * Thu Mar 22 2007 Jeremy Katz <katzj@redhat.com> - 002-1
195 - update for new version
197 * Fri Dec 22 2006 David Zeuthen <davidz@redhat.com> - 001-1%{?dist}
198 - Initial build.