fixes bug where priorities where lost when force-rechecking.
[libtorrent.git] / debian / rules
blob6dd2ee984fc9d21314c7b6d02b9c73127816269f
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
13 # These are used for cross-compiling and for saving the configure script
14 # from having to guess our platform (since we know it already)
15 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
16 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
19 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
20 INSTALL_PROGRAM += -s
21 endif
23 config.status: configure
24 dh_testdir
25 touch config.h.in;\
26 find . -type f -name Makefile.am -print |\
27 sed 's/\.am$$/.in/' |\
28 while read f; do touch "$$f"; done;\
29 touch configure;\
30 ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE)\
31 --prefix=/usr --mandir=\$${prefix}/share/man\
32 --infodir=\$${prefix}/share/info
35 build: build-stamp
36 build-stamp: config.status
37 dh_testdir
38 $(MAKE)
39 touch build-stamp
41 clean:
42 dh_testdir
43 dh_testroot
44 rm -f build-stamp
45 -$(MAKE) distclean
46 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
47 cp -f /usr/share/misc/config.sub config.sub
48 endif
49 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
50 cp -f /usr/share/misc/config.guess config.guess
51 endif
52 dh_clean
55 install: build
56 dh_testdir
57 dh_testroot
58 dh_clean -k
59 dh_installdirs
60 $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
63 # Build architecture-independent files here.
64 binary-indep: build install
65 # We have nothing to do by default.
67 # Build architecture-dependent files here.
68 binary-arch: build install
69 dh_testdir
70 dh_testroot
71 dh_installchangelogs ChangeLog
72 dh_installdocs
73 dh_install --sourcedir=debian/tmp
74 dh_strip
75 dh_compress
76 dh_fixperms
77 dh_makeshlibs -V
78 dh_shlibdeps
79 dh_installdeb
80 dh_gencontrol
81 dh_md5sums
82 dh_builddeb
84 binary: binary-indep binary-arch
85 .PHONY: build clean binary-indep binary-arch binary install