3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
13 DEBROOT
=$(CURDIR
)/debian
/tmp
15 # shared library versions, option 1
19 configure
: configure-stamp
22 # Add here commands to configure the package.
23 .
/waf configure
--prefix=/usr
29 build-stamp
: configure-stamp
32 # Add here commands to compile the package.
33 #./waf ### avoid redundant build here, waf bug
40 rm -f build-stamp configure-stamp
42 # Add here commands to clean up after the build process.
54 # Add here commands to install the package into debian/libprolooks
55 .
/waf
--destdir
=$(DEBROOT
) install
57 # Build architecture-independent files here.
58 binary-indep
: build
install
59 # We have nothing to do by default.
61 # Build architecture-dependent files here.
62 binary-arch
: build
install
68 dh_install
--sourcedir
=debian
/tmp
92 binary
: binary-indep binary-arch
93 .PHONY
: build
clean binary-indep binary-arch binary
install configure