make libprolooks usable from libglade
[libprolooks.git] / debian / rules
blob3f52b421ef02c63d80b7053d5fcfbdbca76fe9a5
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
12 PACKAGE="libprolooks"
13 DEBROOT=$(CURDIR)/debian/tmp
15 # shared library versions, option 1
16 version=0.0.1
17 major=0
19 configure: configure-stamp
20 configure-stamp:
21 dh_testdir
22 # Add here commands to configure the package.
23 ./waf configure --prefix=/usr
25 touch configure-stamp
28 build: build-stamp
29 build-stamp: configure-stamp
30 dh_testdir
32 # Add here commands to compile the package.
33 #./waf ### avoid redundant build here, waf bug
35 touch $@
37 clean:
38 dh_testdir
39 dh_testroot
40 rm -f build-stamp configure-stamp
42 # Add here commands to clean up after the build process.
43 ./waf distclean
44 -rm -rf build
45 -rm -rf .waf*
46 dh_clean
48 install: build
49 dh_testdir
50 dh_testroot
51 dh_clean -k
52 dh_installdirs
54 # Add here commands to install the package into debian/libprolooks
55 ./waf --destdir=$(DEBROOT) install
57 # Build architecture-independent files here.
58 binary-indep: build install
59 # We have nothing to do by default.
61 # Build architecture-dependent files here.
62 binary-arch: build install
63 dh_testdir
64 dh_testroot
65 dh_installchangelogs
66 dh_installdocs
67 dh_installexamples
68 dh_install --sourcedir=debian/tmp
69 # dh_installmenu
70 # dh_installdebconf
71 # dh_installlogrotate
72 # dh_installemacsen
73 # dh_installpam
74 # dh_installmime
75 # dh_installinit
76 # dh_installcron
77 # dh_installinfo
78 dh_installman
79 dh_link
80 dh_strip
81 dh_compress
82 dh_fixperms
83 # dh_perl
84 # dh_python
85 dh_makeshlibs
86 dh_installdeb
87 dh_shlibdeps
88 dh_gencontrol
89 dh_md5sums
90 dh_builddeb
92 binary: binary-indep binary-arch
93 .PHONY: build clean binary-indep binary-arch binary install configure