dev-lang/faust-2.41.1: PV-9999 && stable for arm64
[ladi-overlay.git] / dev-lang / faust / faust-2.41.1.ebuild
blob9c7410095ed4f344387014d50eb6572ea2a8b831
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 SLOT="0"
7 LICENSE="GPL-2"
8 IUSE=""
9 KEYWORDS="~amd64 ~arm64 ~x86"
11 DESCRIPTION="A functional programming language for realtime audio signal processing."
12 HOMEPAGE="https://faust.grame.fr/"
14 if [[ ${PV} == *9999* ]]; then
15 EGIT_REPO_URI="https://git.code.sf.net/p/qsynth/code"
16 inherit git-r3
17 else
18 SRC_URI="https://github.com/grame-cncm/faust/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
19 KEYWORDS="arm64"
22 RDEPEND=""
23 DEPEND=""
25 src_configure() {
26 # prevent static libs from being mangled with LTO
27 #CXXFLAGS+=' -ffat-lto-objects'
28 cmake \
29 -C build/backends/all.cmake \
30 -C build/targets/all.cmake \
31 -DCMAKE_INSTALL_PREFIX=/usr \
32 -DCMAKE_INSTALL_LIBDIR=/usr/lib64 \
33 -DCMAKE_BUILD_TYPE=None \
34 -DINCLUDE_DYNAMIC=ON \
35 -DINCLUDE_STATIC=ON \
36 -DINCLUDE_ITP=ON \
37 -W no-dev \
38 -S build \
39 -B "${P}-build"
42 src_compile() {
43 emake VERBOSE=1 -C "${P}-build"
44 # make VERBOSE=1 -C tools/sound2faust
47 src_install() {
48 # emake DESTDIR="${D}" install
49 emake VERBOSE=1 -C "${P}-build" DESTDIR="${D}" install
50 dodoc README.md
51 # install faust_tutorial.pdf ${D}/usr/share/doc/${P}