reuse app-text/asciidoc for ladoc
[ladi-overlay.git] / app-text / asciidoc / asciidoc-9999.ebuild
blobebeb18c9fbe056e7cbb6e383590a784393730d65
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 DISTUTILS_SINGLE_IMPL=1
7 DISTUTILS_USE_PEP517=setuptools
8 PYTHON_COMPAT=( python3_{9..11} pypy3 )
9 inherit git-r3 distutils-r1 optfeature readme.gentoo-r1
11 DESCRIPTION="A plain text human readable/writable document format (LADI)"
12 HOMEPAGE="https://github.com/LADI/ladoc-py"
13 EGIT_REPO_URI="https://github.com/LADI/ladoc-py.git"
14 EGIT_BRANCH="ladi"
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
20 RDEPEND="app-text/docbook-xml-dtd:4.5
21 >=app-text/docbook-xsl-stylesheets-1.75
22 dev-libs/libxslt
23 dev-libs/libxml2:2"
25 DOC_CONTENTS="
26 If you are going to use a2x, please also look at a2x(1) under
27 REQUISITES for a list of runtime dependencies.
30 src_install() {
31 distutils-r1_src_install
33 # TODO: Consider using Debian patch to allow /usr/share?
34 insinto /usr/share/asciidoc
35 doins -r asciidoc/resources/.
37 readme.gentoo_create_doc
40 pkg_postinst() {
41 readme.gentoo_print_elog
43 optfeature "music filter support" "media-sound/lilypond virtual/imagemagick-tools"
44 optfeature "source filter support" "dev-util/source-highlight dev-python/pygments app-text/highlight"
45 optfeature "latex filter support" "dev-texlive/texlive-latex app-text/dvipng" "dev-texlive/texlive-latex app-text/dvisvgm"
46 optfeature "graphviz filter support" "media-gfx/graphviz"