dev-lang/faust-2.41.1: specfify CMAKE_INSTALL_LIBDIR (as /usr/lib64)
[ladi-overlay.git] / dev-lang / faust / faust-2.41.1.ebuild
blobae7d17ff26322fb9c53d84edac3b7d427a0d2315
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 SLOT="0"
7 LICENSE="GPL-2"
8 IUSE=""
9 KEYWORDS="~amd64 ~arm64 ~x86"
11 DESCRIPTION="A functional programming language for realtime audio signal processing."
12 HOMEPAGE="https://faust.grame.fr/"
13 SRC_URI="https://github.com/grame-cncm/faust/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
15 RDEPEND=""
16 DEPEND=""
18 src_configure() {
19 # prevent static libs from being mangled with LTO
20 #CXXFLAGS+=' -ffat-lto-objects'
21 cmake \
22 -C build/backends/all.cmake \
23 -C build/targets/all.cmake \
24 -DCMAKE_INSTALL_PREFIX=/usr \
25 -DCMAKE_INSTALL_LIBDIR=/usr/lib64 \
26 -DCMAKE_BUILD_TYPE=None \
27 -DINCLUDE_DYNAMIC=ON \
28 -DINCLUDE_STATIC=ON \
29 -DINCLUDE_ITP=ON \
30 -W no-dev \
31 -S build \
32 -B "${P}-build"
35 src_compile() {
36 emake VERBOSE=1 -C "${P}-build"
37 # make VERBOSE=1 -C tools/sound2faust
40 src_install() {
41 # emake DESTDIR="${D}" install
42 emake VERBOSE=1 -C "${P}-build" DESTDIR="${D}" install
43 # dodoc README.md
44 # install faust_tutorial.pdf ${D}/usr/share/doc/${P}