Mark ladish-1 as stable on x86 and amd64
[ladi-overlay.git] / media-sound / ladish / ladish-1.ebuild
blob2e428ec42184c9173aa113cb50b25798d431a0cb
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="5"
7 PYTHON_DEPEND="2"
9 inherit eutils python
11 DESCRIPTION="LADI Session Handler - a session management system for JACK applications"
12 HOMEPAGE="http://ladish.org/"
13 SRC_URI="http://ladish.org/download/ladish-${PV}.tar.bz2"
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="amd64 x86"
18 IUSE="lash python"
20 RDEPEND="!media-sound/lash
21 media-sound/jack-audio-connection-kit[dbus]
22 >=x11-libs/flowcanvas-0.6.4
23 sys-apps/dbus
24 >=dev-libs/glib-2.20.3
25 >=x11-libs/gtk+-2.20.0
26 >=gnome-base/libglade-2.6.2
27 >=dev-libs/dbus-glib-0.74
28 dev-lang/python
29 >=dev-libs/expat-2.0.1"
30 DEPEND="${RDEPEND}
31 virtual/pkgconfig"
33 pkg_setup() {
34 python_set_active_version 2
35 python_pkg_setup
38 src_prepare() {
39 epatch "${FILESDIR}/${P}-include.patch"
42 src_configure() {
43 python_convert_shebangs -r 2 "${S}"
44 local myconf="--prefix=/usr --destdir=${D}"
45 use lash && myconf="${myconf} --enable-liblash"
46 use python && myconf="${myconf} --enable-pylash"
47 einfo "Running \"./waf configure ${myconf}\" ..."
48 ./waf configure ${myconf} || die "waf configure failed"
51 src_compile() {
52 einfo "Running \"./waf build\""
53 ./waf build || die "failed to build"
56 src_install() {
57 einfo "Running \"./waf install --destdir=${ED}"
58 ./waf install --destdir="${ED}" || die "install failed"
59 dodoc AUTHORS README NEWS
60 python_convert_shebangs -r 2 "${ED}"