dev-cpp/libgnomecanvasmm/metadata.xml: adjust maintainer fields
[ladi-overlay.git] / dev-cpp / libgnomecanvasmm / libgnomecanvasmm-2.26.0-r2.ebuild
blobd403ca3659351e3c1a6cea83204b312cdb45f4d7
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 GNOME_TARBALL_SUFFIX="bz2"
8 inherit gnome2
10 DESCRIPTION="C++ bindings for libgnomecanvas"
11 HOMEPAGE="https://www.gtkmm.org"
13 LICENSE="LGPL-2.1"
14 SLOT="2.6"
15 KEYWORDS="~alpha amd64 arm ~ia64 ppc ppc64 sparc x86"
16 IUSE="doc"
18 RDEPEND="
19 >=gnome-base/libgnomecanvas-2.6
20 >=dev-cpp/gtkmm-2.4:2.4
22 DEPEND="${RDEPEND}"
23 BDEPEND="
24 virtual/pkgconfig
25 doc? ( app-doc/doxygen )
28 PATCHES=( "${FILESDIR}"/${P}-disable-building-examples.patch )
30 src_compile() {
31 gnome2_src_compile
33 if use doc; then
34 emake -C docs/reference all
35 HTML_DOCS=( docs/reference/html/. )
39 src_install() {
40 gnome2_src_install
42 rm examples/Makefile* examples/*/Makefile* || die
43 dodoc -r examples
44 docompress -x /usr/share/doc/${PF}/examples