fix repoman warnings
[ladi-overlay.git] / media-sound / jack-audio-connection-kit / jack-audio-connection-kit-1.9.5.ebuild
blob34558d0730bceda5d974ae30fece13858ddaca82
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit multilib
7 DESCRIPTION="Jackdmp jack implemention for multi-processor machine"
8 HOMEPAGE="http://www.jackaudio.org"
9 SRC_URI="http://www.grame.fr/~letz/jack-${PV}.tar.bz2"
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="doc debug freebob dbus"
16 RDEPEND=">=media-libs/alsa-lib-0.9.1
17 freebob? ( sys-libs/libfreebob )
18 dbus? ( sys-apps/dbus )"
20 DEPEND="${RDEPEND}
21 dev-util/pkgconfig
22 doc? ( app-doc/doxygen )"
24 S="${WORKDIR}/jack-${PV}"
26 pkg_setup() {
27 # sandbox-1.6 breaks, on amd64 at least
29 # paludis...
30 if has_version "=sys-apps/sandbox-1.6" && [[ -n $(echo `ps -fp $$`|grep paludis) ]]; then
31 eerror "The compile will hang with =sandbox-1.6. Either downgrade to sandbox-1.4, or use"
32 eerror "PALUDIS_DO_NOTHING_SANDBOXY=1 paludis -i ${PN}"
33 die
36 # portage
37 if hasq "sandbox" ${FEATURES} && ! hasq "-sandbox" ${FEATURES} && has_version "=sys-apps/sandbox-1.6"; then
38 eerror "The compile will hang with =sandbox-1.6. Please use:"
39 echo
40 eerror "FEATURES=\"-sandbox\" emerge ${PN}"
41 echo
42 eerror "OR downgrade sandbox to 1.4 at least."
43 die
47 src_compile() {
48 local myconf="--prefix=/usr --destdir=${D}"
49 use dbus && myconf="${myconf} --dbus"
50 !use dbus && myconf="${myconf} --classic"
51 use debug && myconf="${myconf} -d debug"
52 use doc && myconf="${myconf} --doxygen"
54 einfo "Running \"./waf configure ${myconf}\" ..."
55 ./waf configure ${myconf} || die "waf configure failed"
56 ./waf build ${MAKEOPTS} || die "waf build failed"
59 src_install() {
60 ./waf --destdir="${D}" install || die "waf install failed"