3 TMP
= $(CURDIR
)/debian
/tmp
5 # Make "perl Makefile.PL" be non-interactive.
6 export PERL_MM_USE_DEFAULT
=1
11 override_dh_gencontrol
:
12 debian
/bd-to-depends
>> debian
/koha-common.substvars
15 override_dh_auto_install
:
17 rm $(TMP
)/etc
/koha
/README.txt
18 rm -r
$(TMP
)/usr
/share
/koha
/doc
21 rm $(TMP
)/var
/log
/koha
/README
22 # rm $(TMP)/usr/share/koha/intranet/htdocs/intranet-tmpl/prog/en/lib/jquery/jquery.js
23 # ln -s /usr/share/javascript/jquery/jquery.js \
24 # $(TMP)/usr/share/koha/intranet/htdocs/intranet-tmpl/prog/en/lib/jquery/jquery.js
25 # rm $(TMP)/usr/share/koha/opac/htdocs/opac-tmpl/prog/en/lib/jquery/jquery.js
26 # ln -s /usr/share/javascript/jquery/jquery.js \
27 # $(TMP)/usr/share/koha/opac/htdocs/opac-tmpl/prog/en/lib/jquery/jquery.js
29 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/js
/tinymce
30 ln
-s
/usr
/share
/tinymce2
/www \
31 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/js
/tinymce
33 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/lib
/yui
34 ln
-s
/usr
/share
/javascript
/yui \
35 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/lib
/yui
37 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/lib
/yui
38 ln
-s
/usr
/share
/javascript
/yui \
39 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/lib
/yui
40 install -d
$(TMP
)/etc
/apache2
/sites-available
41 install -d
$(TMP
)/etc
/apache2
/sites-enabled
42 install -d
$(TMP
)/etc
/apache2
/conf.d
43 ln
-s ..
/..
/koha
/koha-httpd.conf
$(TMP
)/etc
/apache2
/sites-available
/koha
44 ln
-s ..
/sites-available
/koha
$(TMP
)/etc
/apache2
/sites-enabled
/koha
45 install -m
0644 debian
/koha.apache-ports
$(TMP
)/etc
/apache2
/conf.d
/koha
46 sed
-i
'/^<VirtualHost 127.0.1.1:/s//<VirtualHost *:/' \
47 $(TMP
)/etc
/koha
/koha-httpd.conf
48 mv
$(TMP
)/etc
/koha
/koha-conf.xml
$(TMP
)/usr
/share
/koha
/koha-conf.xml.in
49 sed
-i
$(TMP
)/usr
/share
/koha
/koha-conf.xml.in \
50 -e
'/^ <user>/s/>.*</>_DBC_DBUSER_</' \
51 -e
'/^ <pass>/s/>.*</>_DBC_DBPASS_</'
52 install -m
0644 koha-tmpl
/opac-tmpl
/prog
/en
/lib
/yui
/skin.css \
53 koha-tmpl
/opac-tmpl
/prog
/en
/lib
/yui
/reset-fonts-grids.css \
54 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
55 install -m
0644 koha-tmpl
/opac-tmpl
/prog
/en
/lib
/yui
/skin.css \
56 koha-tmpl
/opac-tmpl
/prog
/en
/lib
/yui
/reset-fonts-grids.css \
57 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
58 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/menu-button-arrow-disabled.png \
59 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
60 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/menu-button-arrow-disabled.png \
61 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
62 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/menu-button-arrow.png \
63 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
64 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/menu-button-arrow.png \
65 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
66 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow-active.png \
67 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
68 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow-active.png \
69 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
70 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow-disabled.png \
71 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
72 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow-disabled.png \
73 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
74 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow-focus.png \
75 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
76 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow-focus.png \
77 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
78 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow-hover.png \
79 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
80 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow-hover.png \
81 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
82 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow.png \
83 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
84 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow.png \
85 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
86 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/sprite.png \
87 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
88 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/sprite.png \
89 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
90 sed
-i
-e
's:url(.*/reset-fonts-grids.css.*):url(reset-fonts-grids.css):' \
91 -e
's:url(.*/skin.css.*):url(skin.css):' \
92 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
/opac.css \
93 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
/sco.css \
94 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
/staff-global
*.css
95 mkdir
-p
$(TMP
)/debian
/tmp_docbook
96 xsltproc
--output
$(TMP
)/debian
/tmp_docbook
/ \
97 /usr
/share
/xml
/docbook
/stylesheet
/docbook-xsl
/manpages
/docbook.xsl \