3 TMP
= $(CURDIR
)/debian
/tmp
5 # Make "perl Makefile.PL" be non-interactive.
6 export PERL_MM_USE_DEFAULT
=1
9 dh
$@
--fail-missing
--with bash-completion
11 override_dh_gencontrol
:
12 debian
/bd-to-depends
>> debian
/koha-common.substvars
15 override_dh_auto_install
:
17 rm $(TMP
)/etc
/koha
/README.txt
18 rm $(TMP
)/etc
/koha
/SIPconfig.xml
19 rm $(TMP
)/etc
/koha
/log4perl.conf
20 rm -r
$(TMP
)/usr
/share
/koha
/doc
23 rm $(TMP
)/var
/log
/koha
/README
24 install -d
$(TMP
)/etc
/apache2
/sites-available
25 install -d
$(TMP
)/etc
/apache2
/sites-enabled
26 install -d
$(TMP
)/etc
/apache2
/conf.d
27 ln
-s ..
/..
/koha
/koha-httpd.conf
$(TMP
)/etc
/apache2
/sites-available
/koha
28 ln
-s ..
/sites-available
/koha
$(TMP
)/etc
/apache2
/sites-enabled
/koha
29 install -m
0644 debian
/koha.apache-ports
$(TMP
)/etc
/apache2
/conf.d
/koha
30 sed
-i
'/^<VirtualHost 127.0.1.1:/s//<VirtualHost *:/' \
31 $(TMP
)/etc
/koha
/koha-httpd.conf
32 mv
$(TMP
)/etc
/koha
/koha-conf.xml
$(TMP
)/usr
/share
/koha
/koha-conf.xml.in
33 sed
-i
$(TMP
)/usr
/share
/koha
/koha-conf.xml.in \
34 -e
'/^ <user>/s/>.*</>_DBC_DBUSER_</' \
35 -e
'/^ <pass>/s/>.*</>_DBC_DBPASS_</'
36 mkdir
-p
$(TMP
)/debian
/tmp_docbook
37 xt
/verify-debian-docbook.t
38 xsltproc
--output
$(TMP
)/debian
/tmp_docbook
/ \
39 /usr
/share
/xml
/docbook
/stylesheet
/docbook-xsl
/manpages
/docbook.xsl \
43 # exclude history.txt from compression as about.pl needs it uncompressed
44 dh_compress
--exclude
=history.txt
--exclude
=contributors.yaml
--exclude
=teams.yaml