3 TMP
= $(CURDIR
)/debian
/tmp
5 # Make "perl Makefile.PL" be non-interactive.
6 export PERL_MM_USE_DEFAULT
=1
11 override_dh_gencontrol
:
12 debian
/bd-to-depends
>> debian
/koha-common.substvars
15 override_dh_auto_install
:
17 rm $(TMP
)/etc
/koha
/README.txt
18 rm $(TMP
)/etc
/koha
/SIPconfig.xml
19 rm -r
$(TMP
)/usr
/share
/koha
/doc
22 rm $(TMP
)/var
/log
/koha
/README
23 # rm $(TMP)/usr/share/koha/intranet/htdocs/intranet-tmpl/prog/en/lib/jquery/jquery.js
24 # ln -s /usr/share/javascript/jquery/jquery.js \
25 # $(TMP)/usr/share/koha/intranet/htdocs/intranet-tmpl/prog/en/lib/jquery/jquery.js
26 # rm $(TMP)/usr/share/koha/opac/htdocs/opac-tmpl/prog/en/lib/jquery/jquery.js
27 # ln -s /usr/share/javascript/jquery/jquery.js \
28 # $(TMP)/usr/share/koha/opac/htdocs/opac-tmpl/prog/en/lib/jquery/jquery.js
30 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/js
/tinymce
31 ln
-s
/usr
/share
/tinymce2
/www \
32 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/js
/tinymce
34 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/lib
/yui
35 ln
-s
/usr
/share
/javascript
/yui \
36 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/lib
/yui
38 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/lib
/yui
39 ln
-s
/usr
/share
/javascript
/yui \
40 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/lib
/yui
41 install -d
$(TMP
)/etc
/apache2
/sites-available
42 install -d
$(TMP
)/etc
/apache2
/sites-enabled
43 install -d
$(TMP
)/etc
/apache2
/conf.d
44 ln
-s ..
/..
/koha
/koha-httpd.conf
$(TMP
)/etc
/apache2
/sites-available
/koha
45 ln
-s ..
/sites-available
/koha
$(TMP
)/etc
/apache2
/sites-enabled
/koha
46 install -m
0644 debian
/koha.apache-ports
$(TMP
)/etc
/apache2
/conf.d
/koha
47 sed
-i
'/^<VirtualHost 127.0.1.1:/s//<VirtualHost *:/' \
48 $(TMP
)/etc
/koha
/koha-httpd.conf
49 mv
$(TMP
)/etc
/koha
/koha-conf.xml
$(TMP
)/usr
/share
/koha
/koha-conf.xml.in
50 sed
-i
$(TMP
)/usr
/share
/koha
/koha-conf.xml.in \
51 -e
'/^ <user>/s/>.*</>_DBC_DBUSER_</' \
52 -e
'/^ <pass>/s/>.*</>_DBC_DBPASS_</'
53 install -m
0644 koha-tmpl
/opac-tmpl
/prog
/en
/lib
/yui
/skin.css \
54 koha-tmpl
/opac-tmpl
/prog
/en
/lib
/yui
/reset-fonts-grids.css \
55 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
56 install -m
0644 koha-tmpl
/opac-tmpl
/prog
/en
/lib
/yui
/skin.css \
57 koha-tmpl
/opac-tmpl
/prog
/en
/lib
/yui
/reset-fonts-grids.css \
58 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
59 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/menu-button-arrow-disabled.png \
60 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
61 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/menu-button-arrow-disabled.png \
62 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
63 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/menu-button-arrow.png \
64 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
65 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/menu-button-arrow.png \
66 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
67 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow-active.png \
68 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
69 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow-active.png \
70 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
71 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow-disabled.png \
72 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
73 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow-disabled.png \
74 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
75 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow-focus.png \
76 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
77 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow-focus.png \
78 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
79 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow-hover.png \
80 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
81 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow-hover.png \
82 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
83 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow.png \
84 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
85 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow.png \
86 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
87 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/sprite.png \
88 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
89 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/sprite.png \
90 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
91 sed
-i
-e
's:url(.*/reset-fonts-grids.css.*):url(reset-fonts-grids.css):' \
92 -e
's:url(.*/skin.css.*):url(skin.css):' \
93 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
/opac.css \
94 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
/sco.css \
95 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
/staff-global
*.css
96 mkdir
-p
$(TMP
)/debian
/tmp_docbook
97 xsltproc
--output
$(TMP
)/debian
/tmp_docbook
/ \
98 /usr
/share
/xml
/docbook
/stylesheet
/docbook-xsl
/manpages
/docbook.xsl \