3 TMP
= $(CURDIR
)/debian
/tmp
5 # Make "perl Makefile.PL" be non-interactive.
6 export PERL_MM_USE_DEFAULT
=1
9 dh
$@
--fail-missing
--with bash-completion
11 override_dh_gencontrol
:
12 debian
/bd-to-depends
>> debian
/koha-common.substvars
15 override_dh_auto_install
:
17 rm $(TMP
)/etc
/koha
/README.txt
18 rm $(TMP
)/etc
/koha
/SIPconfig.xml
19 rm $(TMP
)/etc
/koha
/log4perl.conf
20 rm -r
$(TMP
)/usr
/share
/koha
/doc
23 rm $(TMP
)/var
/log
/koha
/README
25 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/lib
/tiny_mce
26 ln
-s
/usr
/share
/tinymce
/www \
27 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/lib
/tiny_mce
28 install -d
$(TMP
)/etc
/apache2
/sites-available
29 install -d
$(TMP
)/etc
/apache2
/sites-enabled
30 install -d
$(TMP
)/etc
/apache2
/conf.d
31 ln
-s ..
/..
/koha
/koha-httpd.conf
$(TMP
)/etc
/apache2
/sites-available
/koha
32 ln
-s ..
/sites-available
/koha
$(TMP
)/etc
/apache2
/sites-enabled
/koha
33 install -m
0644 debian
/koha.apache-ports
$(TMP
)/etc
/apache2
/conf.d
/koha
34 sed
-i
'/^<VirtualHost 127.0.1.1:/s//<VirtualHost *:/' \
35 $(TMP
)/etc
/koha
/koha-httpd.conf
36 mv
$(TMP
)/etc
/koha
/koha-conf.xml
$(TMP
)/usr
/share
/koha
/koha-conf.xml.in
37 sed
-i
$(TMP
)/usr
/share
/koha
/koha-conf.xml.in \
38 -e
'/^ <user>/s/>.*</>_DBC_DBUSER_</' \
39 -e
'/^ <pass>/s/>.*</>_DBC_DBPASS_</'
40 mkdir
-p
$(TMP
)/debian
/tmp_docbook
41 xt
/verify-debian-docbook.t
42 xsltproc
--output
$(TMP
)/debian
/tmp_docbook
/ \
43 /usr
/share
/xml
/docbook
/stylesheet
/docbook-xsl
/manpages
/docbook.xsl \
47 # exclude history.txt from compression as about.pl needs it uncompressed
48 dh_compress
--exclude
=history.txt