3 TMP
= $(CURDIR
)/debian
/tmp
5 # Make "perl Makefile.PL" be non-interactive.
6 export PERL_MM_USE_DEFAULT
=1
11 override_dh_gencontrol
:
12 debian
/bd-to-depends
>> debian
/koha-common.substvars
15 override_dh_auto_install
:
17 rm $(TMP
)/etc
/koha
/README.txt
18 rm $(TMP
)/etc
/koha
/SIPconfig.xml
19 rm -r
$(TMP
)/usr
/share
/koha
/doc
22 rm $(TMP
)/var
/log
/koha
/README
23 rm $(TMP
)/etc
/koha
/searchengine
/solr
/config.yaml
24 rm $(TMP
)/etc
/koha
/searchengine
/solr
/indexes.yaml
25 rm $(TMP
)/etc
/koha
/solr
/indexes.yaml
27 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/lib
/tiny_mce
28 ln
-s
/usr
/share
/tinymce
/www \
29 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/lib
/tiny_mce
31 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/lib
/yui
32 ln
-s
/usr
/share
/javascript
/yui \
33 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/lib
/yui
35 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/lib
/yui
36 ln
-s
/usr
/share
/javascript
/yui \
37 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/lib
/yui
38 install -d
$(TMP
)/etc
/apache2
/sites-available
39 install -d
$(TMP
)/etc
/apache2
/sites-enabled
40 install -d
$(TMP
)/etc
/apache2
/conf.d
41 ln
-s ..
/..
/koha
/koha-httpd.conf
$(TMP
)/etc
/apache2
/sites-available
/koha
42 ln
-s ..
/sites-available
/koha
$(TMP
)/etc
/apache2
/sites-enabled
/koha
43 install -m
0644 debian
/koha.apache-ports
$(TMP
)/etc
/apache2
/conf.d
/koha
44 sed
-i
'/^<VirtualHost 127.0.1.1:/s//<VirtualHost *:/' \
45 $(TMP
)/etc
/koha
/koha-httpd.conf
46 mv
$(TMP
)/etc
/koha
/koha-conf.xml
$(TMP
)/usr
/share
/koha
/koha-conf.xml.in
47 sed
-i
$(TMP
)/usr
/share
/koha
/koha-conf.xml.in \
48 -e
'/^ <user>/s/>.*</>_DBC_DBUSER_</' \
49 -e
'/^ <pass>/s/>.*</>_DBC_DBPASS_</'
50 install -m
0644 koha-tmpl
/opac-tmpl
/lib
/yui
/skin.css \
51 koha-tmpl
/opac-tmpl
/lib
/yui
/reset-fonts-grids.css \
52 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
53 install -m
0644 koha-tmpl
/opac-tmpl
/lib
/yui
/skin.css \
54 koha-tmpl
/opac-tmpl
/lib
/yui
/reset-fonts-grids.css \
55 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
56 install -m
0644 koha-tmpl
/opac-tmpl
/lib
/yui
/skin.css \
57 koha-tmpl
/opac-tmpl
/lib
/yui
/reset-fonts-grids.css \
58 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/ccsr
/en
/css
59 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/menu-button-arrow-disabled.png \
60 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
61 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/menu-button-arrow-disabled.png \
62 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
63 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/menu-button-arrow.png \
64 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
65 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/menu-button-arrow.png \
66 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
67 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow-active.png \
68 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
69 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow-active.png \
70 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
71 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow-disabled.png \
72 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
73 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow-disabled.png \
74 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
75 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow-focus.png \
76 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
77 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow-focus.png \
78 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
79 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow-hover.png \
80 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
81 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow-hover.png \
82 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
83 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow.png \
84 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
85 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/split-button-arrow.png \
86 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
87 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/sprite.png \
88 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/prog
/en
/css
89 install -m
0644 koha-tmpl
/intranet-tmpl
/prog
/en
/lib
/yui
/sprite.png \
90 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
91 sed
-i
-e
's:url(.*/reset-fonts-grids.css.*):url("/opac-tmpl/lib/yui/reset-fonts-grids/reset-fonts-grids.css"):' \
92 -e
's:url(.*/skin.css.*):url("/opac-tmpl/lib/yui/assets/skins/sam/skin.css"):' \
93 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/*/en
/css
/opac.css \
94 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/*/en
/css
/sco.css
95 sed
-i
-e
's:href="/opac-tmpl/lib/yui/reset-fonts-grids.css":href="/opac-tmpl/lib/yui/reset-fonts-grids/reset-fonts-grids.css":' \
96 -e
's:href="/opac-tmpl/lib/yui/skin.css":href="/opac-tmpl/lib/yui/assets/skins/sam/skin.css":' \
97 $(TMP
)/usr
/share
/koha
/opac
/htdocs
/opac-tmpl
/ccsr
/en
/includes
/doc-head-close.inc
98 sed
-i
-e
's:url(.*/reset-fonts-grids.css.*):url(reset-fonts-grids.css):' \
99 -e
's:url(.*/skin.css.*):url(skin.css):' \
100 $(TMP
)/usr
/share
/koha
/intranet
/htdocs
/intranet-tmpl
/prog
/en
/css
/staff-global
*.css
101 mkdir
-p
$(TMP
)/debian
/tmp_docbook
102 xt
/verify-debian-docbook.t
103 xsltproc
--output
$(TMP
)/debian
/tmp_docbook
/ \
104 /usr
/share
/xml
/docbook
/stylesheet
/docbook-xsl
/manpages
/docbook.xsl \
107 override_dh_compress
:
108 # exclude history.txt from compression as about.pl needs it uncompressed
109 dh_compress
--exclude
=history.txt