different VALGRIND=1 options
[k8jam.git] / debian / rules
blob2efa6f98309fe6fc49dff3de07eff8bc80c0fd04
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
13 # These are used for cross-compiling and for saving the configure script
14 # from having to guess our platform (since we know it already)
15 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
16 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
19 DESTDIR = $(CURDIR)/debian/k8jam
20 #CFLAGS = -Wall -g
22 #ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
23 # CFLAGS += -O0
24 #else
25 # CFLAGS += -O2
26 #endif
28 # GNU89INLINE = -fgnu89-inline
29 ifneq (,$(findstring thumb,$(DEB_BUILD_OPTIONS)))
30 GNU89INLINE = MAEMO47=1 USE_THUMB=1
31 PROF =
32 else
33 ifneq (,$(findstring k8maemo47,$(DEB_BUILD_OPTIONS)))
34 GNU89INLINE = MAEMO47=1
35 PROF =
36 else
37 GNU89INLINE =
38 PROF = PROFILE=noopt
39 endif
40 endif
43 configure: configure-stamp
44 configure-stamp:
45 dh_testdir
46 sh $(CURDIR)/0build.sh
47 $(CURDIR)/bin.unix/jam configure --prefix=/usr
48 touch $@
51 build: build-stamp
52 build-stamp: configure-stamp
53 dh_testdir
54 # Add here commands to configure the package.
55 $(CURDIR)/bin.unix/jam -a $(GNU89INLINE) $(PROF)
56 touch $@
59 clean:
60 dh_testdir
61 dh_testroot
62 rm -f configure-stamp build-stamp
64 # Add here commands to clean up after the build process.
65 rm -f build-stamp configure-stamp || true
66 rm -f Jamrules.auto.configure || true
67 #$(CURDIR)/bin.unix/jam distclean || true
68 rm -rf $(DESTDIR) || true
70 dh_clean
72 install: build
73 dh_testdir
74 dh_testroot
75 dh_clean -k
76 dh_installdirs
78 # Add here commands to install the package into $(DESTDIR)
79 DESTDIR=$(DESTDIR) $(CURDIR)/bin.unix/jam install $(GNU89INLINE) $(PROF)
82 # Build architecture-independent files here.
83 binary-indep: build install
84 # We have nothing to do by default.
86 # Build architecture-dependent files here.
87 binary-arch: build install
88 dh_testdir
89 dh_testroot
90 dh_installchangelogs
91 # dh_installdocs
92 # dh_installexamples
93 dh_install
94 # dh_installmenu
95 # dh_installdebconf
96 # dh_installlogrotate
97 # dh_installemacsen
98 # dh_installpam
99 # dh_installmime
100 # dh_python
101 # dh_installinit
102 # dh_installcron
103 # dh_installinfo
104 # dh_installman
105 dh_link
106 dh_strip
107 dh_compress
108 dh_fixperms
109 # dh_perl
110 # dh_makeshlibs
111 dh_installdeb
112 dh_shlibdeps
113 dh_gencontrol
114 # maemo-optify
115 dh_md5sums
116 dh_builddeb
118 binary: binary-indep binary-arch
119 .PHONY: build clean binary-indep binary-arch binary install