Added lirc.
[irreco.git] / lirc-0.8.4a / debian / rules
blob30f7aff34b31ccab36dbe243d7aefe2fa4dbbb9b
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
13 # These are used for cross-compiling and for saving the configure script
14 # from having to guess our platform (since we know it already)
15 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
16 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
19 CFLAGS = -Wall -g
21 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
22 CFLAGS += -O0
23 else
24 CFLAGS += -O2
25 endif
28 config.status: configure
29 dh_testdir
30 # Add here commands to configure the package.
31 ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info CFLAGS="$(CFLAGS)" LDFLAGS="-Wl,-z,defs" --with-driver=userspace
34 build: build-stamp
36 build-stamp: config.status
37 dh_testdir
39 # Add here commands to compile the package.
40 $(MAKE)
41 #docbook-to-man debian/lirc.sgml > lirc.1
43 touch $@
45 clean:
46 dh_testdir
47 dh_testroot
48 rm -f build-stamp
50 # Add here commands to clean up after the build process.
51 -$(MAKE) distclean
52 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
53 cp -f /usr/share/misc/config.sub config.sub
54 endif
55 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
56 cp -f /usr/share/misc/config.guess config.guess
57 endif
60 dh_clean
62 install: build
63 dh_testdir
64 dh_testroot
65 dh_clean -k
66 dh_installdirs
68 # Add here commands to install the package into debian/lirc.
69 $(MAKE) DESTDIR=$(CURDIR)/debian/lirc install
72 # Build architecture-independent files here.
73 binary-indep: build install
74 # We have nothing to do by default.
76 # Build architecture-dependent files here.
77 binary-arch: build install
78 dh_testdir
79 dh_testroot
80 dh_installchangelogs ChangeLog
81 dh_installdocs
82 dh_installexamples
83 dh_install
84 # dh_installmenu
85 # dh_installdebconf
86 # dh_installlogrotate
87 # dh_installemacsen
88 # dh_installpam
89 # dh_installmime
90 # dh_python
91 dh_installinit
92 # dh_installcron
93 # dh_installinfo
94 dh_installman
95 dh_link
96 dh_strip
97 dh_compress
98 dh_fixperms --exclude lircd.conf
99 # dh_perl
100 # dh_makeshlibs
101 dh_installdeb
102 dh_shlibdeps
103 dh_gencontrol
104 dh_md5sums
105 dh_builddeb
107 binary: binary-indep binary-arch
108 .PHONY: build clean binary-indep binary-arch binary install