4 Summary: A wiki compiler
6 Group: Applications
/Internet
8 URL: http
://ikiwiki.info
/
9 Source0: http
://ftp.debian.org
/debian
/pool
/main
/i
/%{name}/%{name}_%{version}.tar.gz
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n
)
13 BuildRequires
: perl
(Text
::Markdown
)
14 BuildRequires
: perl
(Mail
::Sendmail
)
15 BuildRequires
: perl
(HTML
::Scrubber
)
16 BuildRequires
: perl
(XML
::Simple
)
17 BuildRequires
: perl
(Date
::Parse
)
18 BuildRequires
: perl
(Date
::Format
)
19 BuildRequires
: perl
(HTML
::Template
)
20 BuildRequires
: perl
(CGI
::FormBuilder
)
21 BuildRequires
: perl
(CGI
::Session
)
22 BuildRequires
: perl
(File
::MimeInfo
)
23 BuildRequires
: gettext
26 Requires: perl
(:MODULE_COMPAT_%
(eval "`
%{__perl} -V
:version`"
; echo $version
))
28 Requires: perl
(Text
::Markdown
)
29 Requires: perl
(Mail
::Sendmail
)
30 Requires: perl
(HTML
::Scrubber
)
31 Requires: perl
(XML
::Simple
)
32 Requires: perl
(CGI
::FormBuilder
)
33 Requires: perl
(CGI
::Session
)
35 Requires: python
-docutils
37 %define cgi_bin
%{_libexecdir}/w3m
/cgi
-bin
41 Ikiwiki is a wiki compiler. It converts wiki pages into HTML pages
42 suitable
for publishing on a website. Ikiwiki stores pages and
history
43 in a revision control system such as Subversion or Git. There are many
44 other features
, including support
for blogging
, as well as a large
51 # Filter unwanted Provides:
52 %{__cat} << \EOF > %{name}-prov
54 %{__perl_provides} $
* |\
55 %{__sed} -e '
/perl
(IkiWiki.
*)/d'
58 %define __perl_provides
%{_builddir}/%{name}/%{name}-prov
59 %{__chmod} +x %{__perl_provides}
61 # Filter Requires, all used by plugins
62 # - Monotone: see bz 450267
63 %{__cat} << \EOF > %{name}-req
65 %{__perl_requires} $
* |\
66 %{__sed} -e '
/perl
(IkiWiki.
*)/d' \
67 -e '
/perl
(Monotone
)/d'
70 %define __perl_requires
%{_builddir}/%{name}/%{name}-req
71 %{__chmod} +x %{__perl_requires}
73 # goes into the -w3m subpackage
74 %{__cat} << \EOF
> README.fedora
75 See http
://ikiwiki.info
/w3mmode
/ for more information.
80 %{__perl} Makefile.PL INSTALLDIRS=vendor PREFIX=%{_prefix}
81 # parallel builds currently don't work
86 %{__rm} -rf %{buildroot}
87 %{__make} pure_install DESTDIR=%{buildroot} W3M_CGI_BIN=%{cgi_bin}
91 %{__rm} -rf %{buildroot}
94 %files -f
%{name}.lang
95 %defattr(-,root
,root
,-)
98 %{_mandir}/man1
/ikiwiki
*
99 %{_mandir}/man8
/ikiwiki
*
101 %dir %{_sysconfdir}/ikiwiki
102 %config(noreplace
) %{_sysconfdir}/ikiwiki
/*
103 # contains a packlist only
104 %exclude %{perl_vendorarch}
105 %{perl_vendorlib}/IkiWiki
*
106 %exclude %{perl_vendorlib}/IkiWiki
*/Plugin
/skeleton.pm.example
108 %doc README debian
/changelog debian
/NEWS html
109 %doc IkiWiki
/Plugin
/skeleton.pm.example
113 Summary: Ikiwiki w3m cgi meta
-wrapper
114 Group: Applications
/Internet
116 Requires: %{name} = %{version}-%{release}
119 Enable usage of all of ikiwiki's web features
(page editing
, etc
) in
120 the w3m web browser without a web server. w3m supports
local CGI
121 scripts
, and ikiwiki can be
set up to run that way using the
122 meta
-wrapper
in this package.
126 %defattr(-,root
,root
,-)
128 %{cgi_bin}/ikiwiki
-w3m.cgi