On QueryException provide the ability to get the connection back out for reuse
[hiphop-php.git] / shell.nix
blobd5d590d0bf84da18cec83a28b4e6f633bd5d1705
2   import
3     (
4       let
5         lock = builtins.fromJSON (builtins.readFile ./flake.lock);
6       in
7       fetchTarball {
8         url = "https://github.com/edolstra/flake-compat/archive/${lock.nodes.flake-compat.locked.rev}.tar.gz";
9         sha256 = lock.nodes.flake-compat.locked.narHash;
10       }
11     )
12     { src = ./.; }
13 ).shellNix