Provide support for enctype aliases for ease of use.
[heimdal.git] / debian / rules
blob113638dbe528f1d05c7f9e7d15199a29f89f5645
1 #!/usr/bin/make -f
3 %:
4 dh $@ --with autoreconf
6 override_dh_auto_configure:
7 dh_auto_configure -- \
8 --prefix=/opt/heimdal --libexecdir=/opt/heimdal/libexec \
9 --with-hdbdir=/var/opt/heimdal --with-readline-lib=/usr/lib \
10 --without-openldap --without-krb4 --with-sqlite3=/usr \
11 --with-readline-include=/usr/include/editline/ \
12 --with-openssl=/usr
14 override_dh_install:
15 dh_install --sourcedir=$(DESTDIR) --list-missing
17 mkdir -m755 -p debian/heimdal/etc/default
18 install -m644 debian/extras/default debian/heimdal/etc/default/heimdal
19 # Fix broken symlink
20 rm debian/heimdal/opt/heimdal/share/man/man5/qop.5
21 ln -s mech.5 debian/heimdal/opt/heimdal/share/man/man5/qop.5
22 # remove unwanted files
23 rm -f debian/heimdal/opt/heimdal/lib/windc.so*
24 rm -f debian/heimdal/opt/heimdal/lib/windc.a
25 rm -f debian/heimdal/opt/heimdal/lib/windc.la
27 rm -f debian/heimdal/opt/heimdal/bin/login
28 rm -f debian/heimdal/opt/heimdal/share/man/man1/login.1
29 rm -f debian/heimdal/opt/heimdal/bin/telnet
30 rm -f debian/heimdal/opt/heimdal/share/man/man1/telnet.1
31 rm -f debian/heimdal/opt/heimdal/bin/ftp
32 rm -f debian/heimdal/opt/heimdal/share/man/man1/ftp.1
33 rm -f debian/heimdal/opt/heimdal/bin/rsh
34 rm -f debian/heimdal/opt/heimdal/share/man/man1/rsh.1
35 rm -f debian/heimdal/opt/heimdal/bin/rcp
36 rm -f debian/heimdal/opt/heimdal/share/man/man1/rcp.1
37 rm -f debian/heimdal/opt/heimdal/bin/su
38 rm -f debian/heimdal/opt/heimdal/share/man/man1/su.1
39 rm -f debian/heimdal/opt/heimdal/bin/kx
40 rm -f debian/heimdal/opt/heimdal/share/man/man1/kx.1
41 rm -f debian/heimdal/opt/heimdal/libexec/kxd
42 rm -f debian/heimdal/opt/heimdal/share/man/man8/kxd.8
43 rm -f debian/heimdal/opt/heimdal/bin/xnlock
44 rm -f debian/heimdal/opt/heimdal/share/man/man1/xnlock.1