gnu: Add nxbelld.
[guix.git] / gnu / packages / abiword.scm
blobb00dac9a63a5b0fe2a3721502f030c842f6d2894
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
5 ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
22 (define-module (gnu packages abiword)
23   #:use-module ((guix licenses) #:prefix license:)
24   #:use-module (guix packages)
25   #:use-module (guix download)
26   #:use-module (guix build-system gnu)
27   #:use-module (guix build-system glib-or-gtk)
28   #:use-module (gnu packages)
29   #:use-module (gnu packages autotools)
30   #:use-module (gnu packages boost)
31   #:use-module (gnu packages compression)
32   #:use-module (gnu packages enchant)
33   #:use-module (gnu packages fribidi)
34   #:use-module (gnu packages fontutils)
35   #:use-module (gnu packages glib)
36   #:use-module (gnu packages gnome)
37   #:use-module (gnu packages gtk)
38   #:use-module (gnu packages image)
39   #:use-module (gnu packages ots)
40   #:use-module (gnu packages popt)
41   #:use-module (gnu packages pkg-config)
42   #:use-module (gnu packages readline)
43   #:use-module (gnu packages wv)
44   #:use-module (gnu packages xml))
46 (define-public abiword
47   (package
48     (name "abiword")
49     (version "3.0.2")
50     (source
51       (origin
52         (method url-fetch)
53         (uri
54           (string-append "https://www.abisource.com/downloads/" name "/" version
55                          "/source/" name "-" version ".tar.gz"))
56         (sha256
57          (base32 "08imry821g81apdwym3gcs4nss0l9j5blqk31j5rv602zmcd9gxg"))
58         (patches
59          (search-patches "abiword-explictly-cast-bools.patch"
60                          "abiword-black-drawing-with-gtk322.patch"))))
62     (build-system glib-or-gtk-build-system)
63     (arguments                   ;; NOTE: rsvg is disabled, since Abiword
64       `(#:configure-flags        ;; supports it directly, and its BS is broken.
65         (list
66           "--enable-clipart"     ;; TODO: The following plugins have unresolved
67           "--enable-templates"   ;; dependencies: aiksaurus, grammar, wpg, gda,
68           (string-append         ;; wordperfect, psion, mathview.
69             "--enable-plugins="
70               "applix " "babelfish " "bmp " "clarisworks " "collab " "command "
71               "docbook " "eml " "epub " "freetranslation " "garble " "gdict "
72               "gimp " "goffice " "google " "hancom " "hrtext " "iscii " "kword "
73               "latex " "loadbindings " "mht " "mif " "mswrite " "opendocument "
74               "openwriter " "openxml " "opml " "ots " "paint " "passepartout "
75               "pdb " "pdf " "presentation " "s5 " "sdw " "t602 " "urldict "
76               "wikipedia " "wmf " "wml " "xslfo"))
77         ;; tests fail with: Gtk-CRITICAL **: gtk_settings_get_for_screen:
78         ;;                  assertion 'GDK_IS_SCREEN (screen)' failed
79         ;;                  GLib-GObject-CRITICAL **: g_object_get_qdata:
80         ;;                  assertion 'G_IS_OBJECT (object)' failed
81         ;; Manually starting the X server before the test phase did not help
82         ;; the tests to pass.
83         #:tests? #f
84         #:make-flags
85         (list "CXXFLAGS=-std=c++11")))
86     (inputs
87       `(("boost" ,boost)
88         ("enchant" ,enchant)
89         ("fontconfig" ,fontconfig)
90         ("fribidi" ,fribidi)
91         ("glib" ,glib)
92         ("goffice" ,goffice)
93         ("gtk+" ,gtk+)
94         ("libchamplain" ,libchamplain)
95         ("libglade" ,libglade)
96         ("libgsf" ,libgsf)
97         ("libjpeg" ,libjpeg)
98         ("libpng" ,libpng)
99         ("librsvg" ,librsvg)
100         ("libxml2" ,libxml2)
101         ("libxslt" ,libxslt)
102         ("ots" ,ots)
103         ("popt" ,popt)
104         ("readline" ,readline)
105         ("telepathy" ,telepathy-glib)
106         ("wv" ,wv)
107         ("zlib" ,zlib)))
108     (native-inputs
109       `(("intltool" ,intltool)
110         ("glib:bin" ,glib "bin")
111         ("libtool" ,libtool)
112         ("pkg-config" ,pkg-config)))
113     (home-page "https://www.abisource.com/")
114     (synopsis "Word processing program")
116     ;; HACKERS: The comment below is here so that it shows up early in the
117     ;; .pot file.
119     ;; TRANSLATORS: Dear translator, We would like to inform you that package
120     ;; descriptions may occasionally include Texinfo markup.  Texinfo markup
121     ;; looks like "@code{rm -rf}", "@emph{important}", etc.  When translating,
122     ;; please leave markup as is.
123     (description "AbiWord is a word processing program.  It is rapidly
124 becoming a state of the art word processor, with lots of features useful for
125 your daily work, personal needs, or for just some good old typing fun.")
126     (license license:gpl2+)))